How to run GUI admin tools remotely?

Alex Katebi alex.katebi at
Sun Jan 25 15:40:35 UTC 2009

On Sun, Jan 25, 2009 at 8:17 AM, Chris G <cl at> wrote:

> I have a backup system in my garage on which I have installed xubuntu
> 8.10.  It would be really useful to be able to administer it remotely
> from my desktop system in my house (also xubuntu 8.10), but none of
> the GUI systems/services admin tools will work because of X security.
> I always get something like the following:-
>    root at garage:/usr/bin# services-admin
>    X11 connection rejected because of wrong authentication.
>    (services-admin:7307): Gtk-WARNING **: cannot open display:
> localhost:10.0

Do you have firewall running on the garage PC? If you don't know then do
"apt-get Install lokkit" then run it and disable firewall. See if that

> Running *user* programs remotely works fine so I have ssh running such
> that X is working OK.  I have also tried all sorts of 'xhosts +'
> commands on the local system such that there should be virtually no X
> authentication at all but I still get the above error.
> Can anyone suggest a way to do this?
> --
> Chris Green
> --
> ubuntu-users mailing list
> ubuntu-users at
> Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-users mailing list