USB thumb drive pulled and icon left on desktop - how do I remove it??

Karl F. Larsen klarsen1 at
Tue Jan 20 00:00:38 UTC 2009

Paul Gupta wrote:
> Karl F. Larsen wrote:
>> Tommy Trussell wrote:
>>> On Sun, Jan 18, 2009 at 6:19 AM, Karl F. Larsen <klarsen1 at> 
>>> wrote:
>>>> Christian Csar wrote:
>>>>> Assuming that when you say you tried to unmount it you mean that you
>>>>> right clicked and selected unmount, then you could also try 
>>>>> unmounting
>>>>> it from the command line i.e. umount /media/disk or something 
>>>>> similar. I
>>>>> believe that if you mounted it in the first place, then you should 
>>>>> not
>>>>> need root privileges.
>>>>    You are wrong. You must be root to use mount and umount in a
>>>> terminal. There are some GUI things that appear to let a non-root 
>>>> mount
>>>> and umount and they work. But they use a root device to do it.
>>>> Karl
>>> NO... you CAN mount and umount devices as a user (non-root) in a
>>> terminal if the device is set with the correct permissions in fstab or
>>> hal. HOWEVER in many cases you will see a conflict because GNOME or
>>> KDE may have mounted the device and it will be busy because it's
>>> "owned" by those processes. SO if you log out of the GUI and use only
>>> a console ("virtual terminal") you won't have any trouble mounting and
>>> umounting devices as a user.
>>> When you use sudo or root to force the device to umount you may
>>> interfere with an active process, and/or you may corrupt data on the
>>> device if its contents have not finished writing.
>>     If this is the case why do I get this error message on Hardy?
>>  karl at karl-hardy:~$ mount -t ext3 /dev/sda2 /mnt
>> mount: only root can do that
>> karl at karl-hardy:~$
>>     This makes me think it needs to be root :-)
>> Karl
> I know this is going to sound silly...
> but have you simply tried rebooting?  The startup scripts tend to 
> clean up this kind of residue left over from unclean mounts...I think? 
> Since it's not going to be detected at boot it shouldn't be left there 
> on the desktop...
    Yes I have rebooted several times. This has been the case since way 
back into the early days. It just takes root to mount another system to 
this one.



	Karl F. Larsen, AKA K5DI
	Linux User
   PGP 4208 4D6E 595F 22B9 FF1C  ECB6 4A3C 2C54 FE23 53A7

More information about the ubuntu-users mailing list