Is it possible to manually activate an eth0 connection?

Bas Roufs basroufs at
Mon Jan 19 13:56:50 UTC 2009

Dear Eberhard, NoOp and Everybody Else at this list

Thanks for all your suggestions so far.
Below, I go through your questions and suggestions in your e-mail from
Friday 16 January 17.55h. For the sake of clarity, I start with a
summary/ synthesis.


When 'DOS' is indicated in the BIOS settings als 'Standard OS, ping
tests reveal connections between the laptop on one hand and the rest
of the network on the other hand: via eth0, the RJ45 accessible LAN
PORT. However, according to 'KMANAGENER', eth0 is still 'unmanaged'.
The browser 'Konqueror' still does not indicate any working internet
connection. One of the possible causes of this problem might be the
three functions of one IRQ only: IRQ 10 dealing with eth0 and 2 other
functions at the same time. I do not yet know how to move those 2
other functions to other, still empty IRQ's.
I am not yet sure, whether is this IRQ 10 problem is the only problem
which hampers the internet connection I am trying to establish.


>> bas at Viaconsensus2:~$ ifconfig -a
>> eth0      Link encap:Ethernet  HWaddr 00:40:ca:bc:9e:88
>>           inet addr:  Bcast:
>>          Mask:
>>           UP BROADCAST MULTICAST  MTU:1500  Metric:1
>>           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>>           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
>>           collisions:0 txqueuelen:1000
>>           RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
>>           Interrupt:10 Base address:0x1800
> ok. This looks pretty good, at least it seems so. ;-)
> Note, that the card is using Interrupt (IRQ) 10

Are you pointing at 'IRQ 10' listed under the heading 'Slave PIC', at
the Wikipedia page on 'interrupt request' (IRQ.)? See:

> Now, from here try to ping your router
> "ping" and your desktop "ping",
> respectively.

Via eth0 (= RJ45-connector in the direct RJ-45 network LAN port)
ping (enter)
connect: Network is unreachable.
ping (enter)
connect: Network is unreachable.

Via eth1 (= RJ45-connector in the RJ-45 interface linked to an
ethernet PCMCIA card): same results!


With respect to the ip address of the router
Frst this line pops up at the terminal black screen:
ping ( 65(84) bytes of data.
Now, in the terminal I see all the times lines running over the screen
with texts like this one:
64 bytes from icmp_sec=558 ttl=254 time=1.16ms
Only the figures right next to "sec=" and 'time=' are different. Every
line adds one second: sec=1, sec=2. sec=559, sec=560, etc. The time
ranges roughly between 0.9 and 1.3ms.

With respect to the ip address of the desktop
The ping test with respect to the desktop ends up in similar results.

Both tests, but via the PCMCIA connection (eth1)
In both cases, the same first line pops up as in the previous 2 tests.
However, all the subsequent lines running over the screen end up like this:
>From icmp_sec=167 Destination Host Unreachable.

General conclusions on the ping tests
When the BIOS settings have been set to 'DOS' as 'standard OS',
ping-communication between the LAN Port and the router/ network is
possible. But with the BIOS-settings set to 'Windows XP', no
ping-communication is possible.
The best results so far come out of the tests with 'eth0' as
communication device. Results from tests via 'eth1', the PCMCIA
ethernet card, are much less interesting. From now on, I focus to
'eth0' for further attempts to establish an effectively working LAN
connection between the laptop and router.

> Post back, whether this works

Yes - see details above.....

>> lo        Link encap:Local Loopback
> [...]
>> pan0      Link encap:Ethernet  HWaddr 5e:2f:b1:00:15:0b
>>           BROADCAST MULTICAST  MTU:1500  Metric:1
>>           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>>           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
>>           collisions:0 txqueuelen:0
>>           RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

> What is this? Presumably this is your pcmcia card??
Now, I am quite sure that the PCMCIA card has nothing to do with these
errors. I do get this 'pan0' feedback with and without my PCMCIA card
in the laptop. From information elsewhere in this thread, it has
become clear that that 'pan' means 'personal area network'. If I
understand this info correctly, 'pan0' implies communication
possibilities for a wireless (WIFI) network via Bluetooth. However it
may be, the presence of Bluetooth in my laptop is being confirmed in
different ways: in the laptop manual as well as on the Unix screen at
start-up and after tests like iconfig.

> ==Have you tried setting your Bios to "DOS", as suggested?
I have done so now.
> What happened?
Interesting result: the test "F c" (enter) apparently results in
communication between the router and the laptop. See above for the

> ==Have you tried using acpi=off on your kernel line in your
> /boot/grub/menu.lst, as suggested?
> What happened?
This is still a white area on my map :-).... I did manage to find and
to open that file via the terminal command "kdesudo
However, it is not clear to me where exactly in that file I should put
the instruction 'acpi=off'. Please, explain!

> ==Have you tried activating your card in the BIOS, as suggested?

> What happened
It may have have resulted in the card being recognised by Linux.
However, it did not or not yet result in a working LAN connection.

> ==Also please have a look at your BIOS to make certain that IRQ 10
> (see above) is not used by anything else?
Taking into account the information from the above mentioned Wikipedia
page on IRQ, I checked within BIOS the so-called 'I/O Device
configuration', also called 'Peripheral configuration'. The only three
issues dealt with there, are 'Serial Port A' (IRQ3 or IRQ 4) 'Serial
Port B' (IRQ3 or IRQ 4) and "Parallel Port" (IRQ 5 or 7). Elsewhere in
BIOS, I found settings for the P2 Mouse (IRQ?), the 4 USB 2 ports
(IRQ?) and the 'Embedded Audio Device' (IRQ5 or IRQ7).

To complete this image, I carried out the unix terminal command
"cat /proc/interrupts". This is the outcome (functions of each IRQ:
see 2nd line)

IRQ    CPU0		

  0:      85422    	XT-PIC-XT  timer

  1:        117   		XT-PIC-XT i8042

  2:          0    		XT-PIC-XT cascade

  3:          1    		XT-PIC-XT

  4:          3    		XT-PIC-XT

  5:        401    		XT-PIC-XT  ehci_hcd:usb1, ohci_hcd:usb2,
ohci_hcd:usb3, ohci_hcd:usb4, SiS SI7012

  7:          2		XT-PIC-XT parport0

  8:          2    		XT-PIC-XT rtc0

  9:          2    		XT-PIC-XT

 10:         56    		XT-PIC-XT  ohci1394, yenta, eth0

 11:          0    		XT-PIC-XT   acpi

 12:      28745    	XT-PIC-XT  i8042

 14:      20683		XT-PIC-XT  pata_sis

 15:       2528    	XT-PIC-XT  pata_sis

NMI:          0   	Non-maskable interrupts

LOC:          0   	Local timer interrupts

RES:          0 	Rescheduling interrupts

CAL:          0   	function call interrupts

TLB:          0   	TLB shootdowns

SPU:          0 	Spurious interrupts

ERR:          0

MIS:          0

Conclusion: IRQ 10 is being used now by more than 1 function: beside
from eth0, also by "ohci1394", and "yenta".
Two questions in this respect:
how to move the latter to functions to other, still empty IRQ's?
do I need to connect 'PAN0', the wireless connection to one of the
IRQ's in order to activate it?

> ==Also try to set any PCI entry in your Bios to "auto", if there are
> IRQs, that are set fixed for certain devices.

I have done so - so far, I do not observe any remarkable difference
between 'auto' and other settings. The PING test apparently have the
same results. But an effectively working LAN connection is still not
there - no internet connection yet. Also the wireless connection does
not work yet, as far as I know.

I hope one or more amongst you can help me to get any remaining
questions answered.

Respectfully Yours,


Bas G. Roufs M.A.
Van 't Hoffstraat 1
NL-3514 VT  Utrecht
M. +31.6.446.835.10
T. +31.30.785.20.40
BasRoufs at

More information about the ubuntu-users mailing list