ssh - connection refused

frmas frmas at
Fri Jan 16 21:54:53 UTC 2009

I've tried to connect my office computer (client) to my home computer
(server), using ssh, but I always have the same message returned when I
run : ssh -p 5317
"ssh: connect to host port 5317; Connection refused".

When I restart ssh from my home computer (server), I have always the
same error message in the auth log file :
Jan 16 22:34:45 serv sshd[12379]: error: Bind to port 5317 on
failed: Address already in use.
(I don't use port 22, and here port 5317 is not the one I use really
;-)), it 's just for the purpose of that message.

This is my /etc/ssh/sshd_config file

Port 5317
Protocol 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
UsePrivilegeSeparation yes
KeyRegenerationInterval 3600
ServerKeyBits 1024
SyslogFacility AUTH
LoginGraceTime 120
PermitRootLogin no
StrictModes yes
RSAAuthentication yes
PubkeyAuthentication yes
AuthorizedKeysFile	%h/.ssh/authorized_keys
IgnoreRhosts yes
RhostsRSAAuthentication no
HostbasedAuthentication no
PermitEmptyPasswords no
ChallengeResponseAuthentication no
PasswordAuthentication no
X11Forwarding yes
X11DisplayOffset 10
PrintLastLog yes
TCPKeepAlive yes
MaxStartups 10:30:60
Banner /etc/
AcceptEnv LANG LC_*
Subsystem sftp /usr/lib/openssh/sftp-server
UsePAM no

Where could be my mistake ? Thanks. Francois

More information about the ubuntu-users mailing list