full windows virtualisation problem on Ubuntu 8.04 and XEN 3.1

edward jordanek edinekj at gmail.com
Wed Jan 14 14:57:32 UTC 2009

I try to setup a fully virtualized Windows XP guest with a Ubuntu
Hardy (8.04) dom0.
The domU launching (with "xm create /etc/xen/winXP.cfg") is without
any error message.
But when I try to connect to it with vncviewer connection is
established but I am not seeing vnc window.
When I comment "disk" line in /etc/xen/winXP.cfg configuration file
vnc I can see vnc window and booting bios messages.
Linux paravirtualisation is working file. I have tried xen on debian
etch and on the same computer and works fine.
(I have eaven tried install ubuntu-xen-server and xen-ioemu-3.1 but
xen python libs not maching - not allow me to run anything at the end)
If you have any suggestion would be welcome...

Installed debs:
xen-ioemu-3.1, libasound2-plugins, libvncserver0-dbg, linux-image-xen,
xen-tools, xen-utils-3.1, bridge-utils

root at ubuntu:/etc# uname -a
Linux ubuntu 2.6.24-23-xen #1 SMP Thu Nov 27 20:14:09 UTC 2008 x86_64 GNU/Linux

dd if=/dev/cdrom of=windowsXP.iso
dd if=/dev/zero of=xenwinXP.img bs=1024k seek=10000 count=0

Uncomment line in /etc/xen/xend-config.sxp:
(network-script network-bridge)

Changed line in /etc/modules to:
loop max_loop=64

Reboot OS

root at ubuntu:/etc/xen# xm create /etc/xen/winXP.cfg
Using config file "/etc/xen/winXP.cfg".
Started domain winXP

When I do xm list - Time is 0.0

root at ubuntu:~# xm list
Name                                      ID   Mem VCPUs      State   Time(s)
Domain-0                                   0  2849     2     r-----     43.1
winXP                                      1  1024     1     ------      0.0

My config file:

import os, re
arch = os.uname()[4]
if re.search('64', arch):
    arch_libdir = 'lib64'
    arch_libdir = 'lib'

kernel = "/usr/lib/xen-ioemu-3.1/boot/hvmloader"
memory = 1024

# Should be at least 2KB per MB of domain memory, plus a few MB per vcpu.
shadow_memory = 8
name = "winXP"
vif = [ 'type=ioemu, bridge=xenbr0' ]
acpi = 1
apic = 1

disk = [ 'file:/home/xen/domains/winXP/xenwinXP.img,hda,w',
'file:/home/xen/iso/windowsXP.iso,hdc:cdrom,r' ]
#disk = [ 'file:/home/xen/iso/windowsXP.iso,sdc:cdrom,r' ]
#disk = [ 'file:/home/xen/iso/windowsXP.iso,sdc:cdrom,r' ]
#disk    = [ 'phy:/home/xen/domains/winXP/xenwinXP.img,ioemu:hda,w',
'file:/home/xen/iso/windowsXP.iso,ioemu:hdc:cdrom,r' ]

device_model = '/usr/' + arch_libdir + '/xen-ioemu-3.1/bin/qemu-dm'

# boot on floppy (a), hard disk (c) or CD-ROM (d)
# default: hard disk, cd-rom, floppy



domid: 22
qemu: the number of cpus is 1
Watching /local/domain/22/logdirty/next-active
qemu_map_cache_init nr_buckets = 10000
shared page at pfn 3ffff
buffered io page at pfn 3fffd
Time offset set 0
I/O request not ready: 0, ptr: 0, port: 0, data: 0, count: 0, size: 0
Triggered log-dirty buffer switch

title           Xen 3.1 / Ubuntu 8.04.1, kernel 2.6.24-23-xen
root            (hd0,0)
kernel          /boot/xen-3.1.gz
module          /boot/vmlinuz-2.6.24-23-xen
root=UUID=cfb67115-121b-4ad4-a9ae-c9f4b0943a17 ro console=tty0
module          /boot/initrd.img-2.6.24-23-xen

root at ubuntu:/etc# dpkg -l | grep xen
ii  libxen3.1                             3.1.0-0ubuntu19
library interface for Xen, a Virtual Machine
ii  linux-image-2.6.24-23-xen             2.6.24-23.46
Linux kernel image for version 2.6.24 on Thi
ii  linux-image-xen             
Real time Linux kernel image
ii  linux-ubuntu-modules-2.6.24-23-xen    2.6.24-23.36
Ubuntu supplied Linux modules for version 2.
ii  python-xen-3.1                        3.1.0-0ubuntu19
python bindings for Xen, a Virtual Machine M
ii  xen-hypervisor-3.1                    3.1.0-0ubuntu19
The Xen Hypervisor for i386, amd64 amd lpia
ii  xen-ioemu-3.1                         3.1.0-0ubuntu19
XEN administrative tools
ii  xen-tools                             3.8-4ubuntu4
Tools to manage debian XEN virtual servers
ii  xen-utils-3.1                         3.1.0-0ubuntu19
XEN administrative tools


More information about the ubuntu-users mailing list