Unbootable Laptop after GRUB removal

Abhischek Thottakara abhischek_t at hotmail.com
Mon Jan 5 12:59:47 UTC 2009

I have an unbootable laptop because I removed GRUB by formating my Ubuntu 64-Bit partition. I know that you need to restore the Vista MBR to get a bootable machine again but I do not have a recovery cd so I researched on the Internet and found a way using the UBUNTU- Live CD. I followed the instructions on this webpage http://ubuntuforums.org/showthread.php?t=622828 the exact commands were: sudo apt-get install syslinux
sudo dd if=/usr/lib/syslinux/mbr.bin of=/dev/sda
and sudo apt-get install mbr
sudo install-mbr -i n -p D -t 0 /dev/sda
Both commands did not work that's why I tried both, it said that they completed successfully but I could not boot Vista again. Now the Grub error was gone but the machine said MBR 123FA with a blinking cursor. At that time I did not know what that was and I got totally desperate because I thought I deleted my Vista partition. So I googled again and found a forum where someone had quite the same problem and she solved it using "SUPERGRUBDISK"  http://www.supergrubdisk.org/. I downloaded the iso, burned it and started the cd, then I went to the windows section on the cd and selected the Option Restore Windows MBR, then there was a Menu where it said remove GRUB and restore Windows MBR it prompted me to select the OS which was installed before Linux and the only thing I could select was called "SYSLINUX"  I have know idea what that is and in my despair I selected it hoping that it would restore Vista MBR. But now the laptop is even "more unbootable" because when I start the laptop it says: ""BOOTMGR is missing, Press Ctrl+Alt+Del to restart". " Again I researched on the Internet where I found many advices saying the only way is getting an recovery cd. So I called my friend who has a recovery cd for his laptop but which is only 32- Bit. I started the cd and went to "REPAIR COMPUTER" option. The first thing I noticed that there was no entry for previous Vista Installations to repair but as the "internet" said I opened Recovery Console or "Repair Command & Prompt" as it is called now and used all three commands which were: "bootrec /fixmbr, bootrec /fixboot, bootrec /rebuildbcd". The first two completed successfully, but the third failed with the output something like this: "No Windows Version, and some numbers I can't quite remember". But it changed nothing my Laptop is still unbootable with the message "BOOTMGR is missing..."
Please help me I am grateful for all the help I can get!
Thanks in advance
Show them the way! Add maps and directions to your party invites. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20090105/55c8b8b8/attachment.html>

More information about the ubuntu-users mailing list