Can't upgrade to Jaunty, half upgrade has hobbled computer.

Dave M G martin at
Tue Apr 28 05:07:16 UTC 2009

Ubuntu users,

I filed a bug report about this, but it is seeing no action, and I do 
need my computer running again as soon as possible.

I tried to use the update manager to upgrade from 8.10 to Jaunty 9.04 
final release version (on April 27), and it did a partial upgrade and 
aborted without much warning. It left my computer in an unstable state, 
where applications, like Gnome applets, were crashing.

I rebooted, and Compiz won't load, and it won't read data CDs, and 
Nautilus won't run.

I tried running the upgrade again, and got this error:

Can't install 'ubuntu-desktop'
It was impossible to install a required package. Please report this as a 

When I close that window, it gives me a window to install only one 
package, ubuntu-desktop. So I press the "Start upgrade..." button, and 
get this error:

The upgrade is now aborted. Your system could be in an unusable state. A 
recovery will run now (dpkg --configure -a).
Please report this bug against the 'update-manager' package and include 
the files in /var/log/dist-upgrade/ in the bug report.
installArchives() failed

After that, I press the "close" button on the error message, and the 
upgrade manager quits.

Here is the output of "dpkg --configure -a":

dpkg: dependency problems prevent configuration of ubuntu-desktop:
 ubuntu-desktop depends on checkbox-gtk; however:
  Package checkbox-gtk is not installed.
 ubuntu-desktop depends on gnome-applets; however:
  Package gnome-applets is not installed.
 ubuntu-desktop depends on gnome-session-canberra; however:
  Package gnome-session-canberra is not installed.
 ubuntu-desktop depends on gstreamer0.10-pulseaudio; however:
  Package gstreamer0.10-pulseaudio is not installed.
 ubuntu-desktop depends on nautilus; however:
  Package nautilus is not installed.
 ubuntu-desktop depends on notify-osd; however:
  Package notify-osd is not installed.
 ubuntu-desktop depends on pulseaudio; however:
  Package pulseaudio is not installed.
 ubuntu-desktop depends on pulseaudio-esound-compat; however:
  Package pulseaudio-esound-compat is not installed.
dpkg: error processing ubuntu-desktop (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

I tried installing some dependancies with Synaptic, but they all in turn 
reported other dependency problems.

The bug report is here:

My computer is now in an unuseable state, so I hope someone can help me 
resolve this soon.

Thanks for any help.

Dave M G

More information about the ubuntu-users mailing list