the infamous linux wifi monster strikes-wirechief, Leonard, and marc

Robert Holtzman holtzm at
Tue Apr 21 23:36:51 UTC 2009

On Tue, 21 Apr 2009, Nils Kassube wrote:

> Robert Holtzman wrote:


>>> Which configuration utility? I don't think there is a configuration
>>> utility that can guess the pass phrase.
>> The web configuration utility ( has an option to
>> automatically enable encryption, including generation of a key
>> (pass phrase?). I have been told on another list that this only works
>> with Windows. I won't dispute that but it does populate the router
>> with the key (pass phrase?). Moot point however. I still couldn't
>> connect.
> Ah, _that_ configuration utility. Sorry, I didn't remember it exists
> because it is Windows only and I never even tried to use it. For me it
> is just a pretty icon on the config page :)

I assume you're referring to the option to automatically enable 
encryption. If so, as a matter of curiosity, if it's for Windows only, 
why does it populate the router (and IIRC wicd also) with a key?


> Well, using the encrypted passwords file is just another method to do
> the same thing. Therefore I would assume you did it right and you
> should be able to connect on the wireless link.

Yup.....sure should.

> Now there are 2
> remaining questions. You wrote " connection after reboot".
> Does that mean that you had a connection before reboot? And did you
> tell wicd to automatically connect to your network?

I didn't mean to give the impression that I had a connection before 
reboot. I have never achieved a connection with encryption enabled.

> Finally, I just installed Wicd and made the connection to the WRT54GL
> with my laptop which has a 2200BG wireless card. It worked without a
> problem.

I hate people like that. They exist to torment me.

>> Again, any chance this could be a hardware or firmware problem.
> Yes, that is possible. But I can't tell you on which side the problem
> is.

I posted the problem to my local LUG list. An individual I consider to 
be quite knowledgeable just replied in part that "The source your 
firmware is running has the known WPA/WPA2 encryption issues" I need to 
do some more research on that.

Thanks again for your help.

Bob Holtzman
"If you think you're getting free lunch,
  check the price of the beer"

More information about the ubuntu-users mailing list