Cannot compile Iproute - solved

Jose Rodriguez joheiker at gmail.com
Wed Apr 15 01:20:46 UTC 2009


------------------------------

>
> Message: 2
> Date: Tue, 14 Apr 2009 18:44:35 +0300
> From: "Mihamina Rakotomandimby (R12y)" <mihamina at lab.vectoris.fr>
> Subject: Re: Cannot compile Iproute
> To: "Ubuntu user technical support,     not for general discussions"
>        <ubuntu-users at lists.ubuntu.com>
> Message-ID: <49E4AF63.7000400 at lab.vectoris.fr>
> Content-Type: text/plain; charset=windows-1252; format=flowed
>
> Jose Rodriguez wrote:
> Greetings everyone!
>
> Im using Ubuntu 8.04, kernel 2.6.29. Im trying to compile a source code for
> Iproute that i downloaded for this kernel b/c from the one i have by default
> i can see it's source code, i only see headers and some files when i look at
> /etc/iproute2. I need the whole thing. So, when i compile i get this error
>
> make[1]: se ingresa al directorio `/home/jose/Escritorio/
> iproute2-2.6.29/lib'
> make[1]: No se hace nada para `all'.
> make[1]: se sale del directorio `/home/jose/Escritorio/iproute2-2.6.29/lib'
> make[1]: se ingresa al directorio
> `/home/jose/Escritorio/iproute2-2.6.29/ip'
> gcc -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I../include
> -DRESOLVE_HOSTNAMES -DLIBDIR=\"/usr/lib/\"   -c -o link_gre.o link_gre.c
> In file included from link_gre.c:15:
> ../include/linux/if_tunnel.h:33: error: el campo ‘iph’ tiene tipo de dato
> incompleto
> link_gre.c: En la función ‘gre_parse_opt’:
> link_gre.c:136: aviso: declaración implícita de la función
> ‘__constant_htons’
> make[1]: *** [link_gre.o] Error 1
> make[1]: se sale del directorio `/home/jose/Escritorio/iproute2-2.6.29/ip'
> make: *** [all] Error 2
>
> I've been searching and to solve it i need to have the build-essential
> package, ubuntu-modules, linux-headers, linux-restricted-modules. I do have
> them installed but for the 2.6.24.23. I have all the kernel source code for
> the 2.6.29 kernel im using right now. I downloaded from kernel.org.
>
> So, does anyone has an idea what could be the problem???
>
> If i use Sypnatic it wont show me anything for 2.6.29 kernel. But i dont
> think how this could be the problem if i have all the kernel code.
>
> Just get the source package!
>
>
> http://packages.ubuntu.com/search?suite=default&section=all&arch=any&searchon=names&keywords=iproute
>

I tried that link but when i install the iproute it says that i have a newer
version installed. And before i explained that i download iproute for the
kernel im using, including the source code.

Anyways, it seems the problem was in one of the files. In if_tunnel.h i just
had to add include<ip.h> and then i had to copy ip.h from the kernel code to
the directory iproute2/include/linux. I downloaded the files on my desktop.
ip.h is in usr/src/linux/include/linux/.

That was it!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20090415/fa67d4b5/attachment.html>


More information about the ubuntu-users mailing list