[Jaunty] Grub problem after update

Amedee Van Gasse (Ubuntu) amedee-ubuntu at amedee.be
Fri Apr 10 12:54:14 UTC 2009


On Thu, April 9, 2009 21:10, Jim Smith wrote:
> Yesterday I ran about 80+ updates which included grub. Since then this
> laptop won't boot the first kernel but will drop into Busybox and give the
> error message "ALERT! /dev/disk-by-UUID/=UUID= (UUID given) does not
> exist." Running sudo gedit /boot/grub/menu.lst shows that all the UUIDs
> given are identical for all kernels and identical to the UUID given in the
> error message. Second kernel will boot normally. My menu.lst is attached
> in case I missed anything, running "sudo update-grub" picks up all the
> kernels but the end result is the same, firtst kernel will not boot.
>
> Any ideas?

If one kernel boots, and the other doesn't, and both have the same
parameters, then there is something wrong with one of the kernels, not
with grub.
I saw that you solved the problem by reinstalling the kernel. The problem
was probably the initrd, regenerating it would probably also have solved
the problem. But I'd have to look up the exact syntax.


I have two tangents on this topic:

* I'm using labels, not UUIDs. In grub, but also in fstab.
The result is the same but my small brain works better with labels. ;-)

* Is anyone else using grub-pc aka grub2? I installed it a couple of days
ago. I took a little time to learn how to work with it, and it works
really nice for me.

-- 
Amedee







More information about the ubuntu-users mailing list