DVD-Writer issues Ubuntu Linux

Mihai Tanasescu mihai at duras.ro
Thu Apr 9 08:44:54 UTC 2009


Robert Parker wrote:
> On Thu, Apr 9, 2009 at 4:35 AM, Mihai Tanasescu <mihai at duras.ro> wrote:
>   
>> Mihai Tanasescu wrote:
>>     
>  And again..some other tests and the final ones..
>   
>> Apparently anything k3b, brasero, gnome baker related fails in writing
>> any DVD be it DVD+R, or be it DVD+RW.
>>
>> On the other side the builtin Nautilus Writer works as good as Nero did
>> in Windows.
>>
>> How can I get K3B and the others to work ?
>> I suspect the problem is somewhat related to the underlying tools they
>> are using...particularly growisofs, etc.
>>     
>
> I am using 8.10 and have installed growisofs. I've been using it to
> burn DVDs for years on various Debian systems without any problem.
> Also over those years I used cdrecord compiled from source for CD
> burning again without problem. OTOH those using K3b had been for ever
> in trouble because that used the Debian fork of cdrecord called
> 'wodim'. Presently I am not burning CDs and DVDs day after day the way
> I once did on Debian 3.0 and 3.1 but my experience so far indicates
> that:
> 1. wodim will burn CDs. The man page states that it will burn DVDs but
> I have not tried it.
>   
You're right...I have wodim installed after I checked a bit but K3B from 
the debugging output seems to be using growisofs for DVD burning, so I'm 
inclining to think the problem is located there somewhere.
> 2. growisofs burns DVDs without problem but I had to install it.
> 3. I avoid using brasero for 2 reasons, firstly it builds the iso
> image on my main drive whereon I have no room to do it. I have not
> found any way to specify the iso build location. Secondly when I burnt
> an iso to cd it simply installed the iso as a file on the cd. Yes that
> was back in the days when I had enough room on my main drive to wrap
> the iso in another iso.
>
> I think that there is no way that growisofs is causing your problems
> since it is not installed by default [1] though some of its libraries
> are. If wodim is causing your problems and I suspect that it is, it
> will take years to fix if the experience with cd burning is anything
> to go on.
>   
For me it came installed (maybe as a dependency to k3b ?) and is 
included in a dvd-rw package.

Are you sure K3B is using wodim and not growisofs  for this ? (I might 
have looked the wrong way..as I didn't spend too much time with this)

4-5 years ago while in faculty I was using cdrecord for plain cd burning 
and it was great, back then I was all console..even for watching movies 
via the framebuffer.

Now for my home PC I'd like to have it more friendly so that's why I was 
attempting at K3B.

A funny thing happened this morning...as before going towards my 
workplace I had the curiosity to still try stuff.
I took the wodim Jaunty package and installed (also fixing dep problems 
along the way).
I tried with K3B writing a DVD+RW and a DVD+R and it worked (the first 
one by default, the DVD+R worked by dropping the speed manually to 12x 
instead of the auto detected 16x, after throwing another DVD out the trash).
This might very well be a coincidence..as the DVD+RW which worked..is 
handled by growisofs from what I knew in K3B.
Now I reverted back to the previous wodim package and still got a 
similar result.

I'm having a real trouble at grasping the issue and I still want my PC 
at home to have a friendly cd writing interface:)
Tonight I'll try Nero for Linux..as I'm curious if it uses some sort of 
direct device interaction and if it works when compared with K3B + 
underlying tools.
This problem is really making me very curious to dig for more and see 
the root cause.

Thanks for your help.

> By your posts you are obviously keen to learn and capable of it. You
> might want to consider learning to use wodim, genisoimage and
> growisofs at CLI and so keep control of your burning in your own
> hands.
>   
I always enjoy strange issues/problems because they make me want to 
discover what's happening and are more challenging.
> [1] I am using a derivative of Ubuntu 8.10, eeebuntu 8.10 so maybe my
> setup differs. Try 'man growisofs' to see.
>
> Bob Parker
>
>
>   





More information about the ubuntu-users mailing list