GNOME Partition Editor - evolved into problem with chmod

Bret Busby bret at
Fri Apr 3 19:11:31 UTC 2009

On Fri, 3 Apr 2009, Thorny wrote:

> On Fri, 03 Apr 2009 16:01:52 +0300, Mihamina Rakotomandimby (R12y) posted:
>> Bret Busby wrote:
>>>> # /dev/sda1
>>>> UUID=8ee9b4b5-98f9-4849-93bf-cec44029ae8e /public	ext3 defaults  0 0
>>>> The UUID is from the "vol_id -u /dev/sda1" command
>>> "Ah, there's the rub" (From Hamlet, I believe).
>> Uh? I dont know Hamlet ;-)
>>> If I try to get the UUID for the partition, by using the "vol_id -u"
>>> command, it returns "error opening device", I assume, because the device
>>> is not mounted.
>> Make a:
>>      fdisk -l
>> to see your available partitions.
> That command won't give you the UUID of the partitions.
> The command blkid will show the UUID of the partitions. Even unmounted
> ones, Bret.

I don't know whether blkid has to be run as a superuser, but, when I ran 
the command, I got no response.

I entered that command, and then the system just returned to the command 
prompt, with no response displayed.

The previously mentioned (in the thread) command
ls -l /dev/disk/by-uuid
worked; it listed uuid's for each partitition.

I entered the uuid's appropriately (I think) in the fstab file, and 
tried two different positionings, but the amending of the fstab file, 
did not result in the partitions being mounted.

To ensure no typographical errors in the UUID entris in the fstab file, 
I copied and pasted the respective UUID's from the response to the ls 
comand cited above.

I used the format
# <device>
<UUID>	ext3 	<mountpoint>	defaults	0	0

for each of the two partitions that I wanted to be mounted.

both of the partitions are ext3 partitions.

I figured that the use of defaults would be okay, as it is used in the 
first data line of the file; the proc line.

Then, I rebooted, after each positioning.

man fstab made the point that the order of the listings in the fstab 
file, is important, and that it is up to the syadmin to figure out how 
to order them (thus, I do not know the required order).

I tried first with the order
floppy drive

which was the order as originaly, apart from the insertion of the two 

When that did not work, as the Debian fstab has data partition(s) before 
the / mountpoint, I shifted the two mypartition lines, to between the 
proc line and the / line in the fstab

After each attempt, I ran df -h, to find whether the two partitions were 
listed, and, they weren't included in the listing, so I tried looking 
using the Ubuntu equivalent of the File Browser, and I did not find the 
partions, so I assume that they did not get mounted, in each of the two 

So, I still cannot get the two partitions to get mounted, via the fstab 
file, in Ubuntu.

Bret Busby
West Australia

"So once you do know what the question actually is,
  you'll know what the answer means."
- Deep Thought,
   Chapter 28 of Book 1 of
   "The Hitchhiker's Guide to the Galaxy:
   A Trilogy In Four Parts",
   written by Douglas Adams,
   published by Pan Books, 1992


More information about the ubuntu-users mailing list