Installing mysql-server doesn't create any users

Preston Hagar prestonh at
Thu Apr 2 22:21:52 UTC 2009

On Thu, Apr 2, 2009 at 4:14 PM, Hal Burgiss <hal at> wrote:
> I've never had trouble with a mysql installation. I would be inclined
> to do a 'remove --purge', then look around the filesystem (like in
> /var/lib/mysql), and phsyically remove any pieces I found, and then
> start fresh.
> --
> Hal

Thanks for the response.  I finally figured it out myself.  For some
reason, my /tmp directory on my server didn't have write permissions
for group and other.  I found that out after I tried running


and saw that it failed to create a tmp file in /tmp.  After correcting
the permissions, I tried running mysql_install_db as well as doing a
dkpg-reconfigure and a apt-get remove followed by an apt-get install.
Finally I did more or less as suggested above and did a

dpkg -P mysql-server-5.0

to completely purge it.  After that, I reinstalled it with apt-get and
everything worked great.  I have no idea how or why /tmp had its
permissions changed, but apparently the fact that it couldn't write a
tmp file in there was causing a silent failure (as far as the deb
package installer was concerned) that wouldn't allow it or me to
create a user.

Anyway, it is fixed now.  Thanks for the help.


More information about the ubuntu-users mailing list