offlineimap: md5 deprecation warning

Jamie Griffin jpg at gmx.com
Thu Apr 2 18:53:18 UTC 2009


Hi

I'm just installed the development version, 9.04, and offlineimap using apt. 

When i run offlineimap i get a warning saying an md5 module is deprecated. I'm not sure what i need to do to fix it. It says i need to "use hashlib" instead. Does anyone know if can install this using apt to fix it, or if it is a bug? 

Thanks for any help on this, Jamie. 

Here is the error message i'm getting.:

-------------------------------------------------------------------
/var/lib/python-support/python2.6/offlineimap/folder/Maildir.py:23: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import os.path, os, re, time, socket, md5
------------------------------------------------------------------- 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20090402/fa4a7d0c/attachment.pgp>


More information about the ubuntu-users mailing list