update-grub not updating grub after dist-upgrade

NoOp glgxg at sbcglobal.net
Thu Oct 23 17:08:57 UTC 2008

On 10/23/2008 07:09 AM, Brian McKee wrote:
> Hi All,
> I upgraded a Hardy machine last night with 'at 7pm aptitude -y
> dist-upgrade && shutdown -r now'
>> Setting up linux-ubuntu-modules-2.6.24-21-generic (2.6.24-21.32) ...
> Looking at /boot/menu.1st I see it actually chose option 2 - keep local
> Now my question is, how can I get that kernel added to grub without me
> doing it by hand now?
> I've tried
>> update-grub
>> dpkg-reconfigure -phigh linux-image-2.6.24-21-generic
>> dpkg-reconfigure -plow linux-image-2.6.24-21-generic
>> aptitude reinstall linux-image-2.6.24-21-generic
> None of them seem to put that -21 kernel back in grub.menu
> As I've said before, sure I can do it by hand, but I don't understand
> why it's not doing it itself....
> Here's the entire grub file without the comments or blank lines
> Comments appreciated
> Brian

Ah. I had exactly that problem on one of my machines yesterday... Only
in my case it has been running -19 just fine for quite some time & I
noticed that -21 wasn't showing up in the menus. It's a bug somewhere
(don't know where) as I also ended up with 2 -19's in the menu even
after using all the standard sudo's: 'update-grub', 'update-initramfs -c
-k all', 'grub' etc.

I was planning to use SuperGrub to fix the problem, but I finally just
edited the grub menu by hand; changed all instances of -19 in the first
set to -21 and rebooted. Worked just fine. Note: you can always modify
back to -19 at the grub boot menu if you run into problems with -21.

More information about the ubuntu-users mailing list