Booting problem

Mark Haney mhaney at
Mon Oct 6 13:25:34 UTC 2008

Keith Powell wrote:
> My set-up here is two internal hard drives. One has XP on it and the 
> other Ubuntu  8.04.1. Each installation is entirely separate. While the 
> BIOS is booting, I select which hard drive to use.
> This has been working perfectly until a couple of days ago. Now I am 
> having a big problem!
> With only the Ubuntu hard drive plugged in, it boots correctly.
> However, with both hard drives plugged in, Ubuntu starts booting and 
> then stops with the error message:
> BusyBox v1.1.3 (Debian 1:1.1.3-5ubuntu12) Built-in shell (ash)
> Enter 'help' for a list of built-in commands
> (initramfs)_

It looks like initrd is doing something stupid.  Possibly with the way 
the drives are now being discovered or mapped.

> I have tried rebooting in safe mode, but get the same message.
> I have tried using the XP System restore and going back to an earlier 
> point (in case there was an XP problem).
> I have even reinstalled Ubuntu with the XP drive unplugged.

This isn't XP related at all if Ubuntu is the one not booting properly.
> All are the same: Ubuntu is OK if XP is unplugged, no good if it's 
> plugged in. For information, XP runs whether both drives are plugged in 
> or if the Ubuntu is unplugged.

Can you try using a previous kernel with both drives plugged in?  It 
almost sounds like a kernel upgrade has included an initrd (as shown by 
the 'initramfs_' line) that is funky with your system.

That's about the only option I can give you without cracking open the 
initrd image on that kernel.

> It's defeated me and I don't know what's causing it.
> Any ideas, please? (Apart from "Don't use Windows!!)
> Many thanks
> Keith

Libenter homines id quod volunt credunt -- Caius Julius Caesar

Mark Haney
Sr. Systems Administrator
ERC Broadband
(828) 350-2415

Call (866) ERC-7110 for after hours support

More information about the ubuntu-users mailing list