Vector rendering

Chris Mohler cr33dog at gmail.com
Thu Oct 2 20:15:22 UTC 2008


On Thu, Oct 2, 2008 at 2:51 PM, NoOp <glgxg at sbcglobal.net> wrote:
> On 10/02/2008 10:58 AM, Chris Mohler wrote:
>> On Thu, Oct 2, 2008 at 11:42 AM, NoOp <glgxg at sbcglobal.net> wrote:
>>> On 10/01/2008 10:17 PM, H.S.Rai wrote:
>>>> Website http://demo.binyasit.com/mapediting/  says:
>>>>
>>>>  "Your browser does not support vector rendering. Currently supported
>>>> renderers are: SVG VML"
>>>>
>>>> Using Firefox 3.0.3 on Ubuntu.
>>>>
>>>> May I get any solution.
>>>>
>>>> --
>>>> H.S.Rai
>>>>
>>>
>>> Works for me using SeaMonkey 1.1.12 (Mozilla version)
>>> Works for me using Fx 2.0.0.14 and 2.0.0.17 (Mozilla version)
>>> Same error that you get using Fx 3.0.3 (Ubuntu version)
>>>
>>> All tested from the same machine - even tried it with all
>>> add-ons/extensions removed from Fx 3.0.0.3. File a bug:
>>> https://bugs.launchpad.net/ubuntu/+source/firefox-3.0/
>>
>> I doubt this is a FF bug.  I bet that one of the myriad javascript
>> files being included contains a browser switch that is excluding FF3.
>> FF3 does indeed support SVG rendering  AFAICT.  Head over to
>> openclipart.org - I have yet to see FF3 barf on any of the SVG there,
>> and some of it is badly formatted.
>>
>> I took a peek at the included JS on that page, but some of it includes
>> even more JS so I gave up - looked like a time-consuming adventure ;)
>>
>> Chris
>>
>
> Well, I used Fx3 and went to the url using browser spoofing as Fx2 with
> the exact same error results. So... I reckon that it just may be a Fx3
> issue and/or an Fx3 and the site combination issue.

Ah - I should have thought to spoof the UA string.  Good thinkin' :)

Chris




More information about the ubuntu-users mailing list