Intrepid Sound Problems

Daniel T Chen crimsun at
Sat Nov 15 23:18:08 UTC 2008

On 11/14/2008 03:43 PM, Karl Larsen wrote:
>      I did a search today to try and get sound back on my new Intrepid. I
> see this is a MAJOR problem and there are 25 web pages full of
> mis-information.
>      First, the sound was perfect yesterday. Turned off the laptop and
> this morning when it booted up the little speaker's had a red X over
> them. I cleared that by right clicking and setting it right. No idea how
> it got changed.
>      I tried the w32codecs which was worthless, turned of PulseAudio
> worthless, and began to wonder what is going on.
>      I did get some drivers for Firefox to view U-Tube things and tried
> to install a special driver that apt-get could not find which was
> supposed to fix the sound problem. I will continue to Google but will
> avoid all bug reports because they are VERY confusing.
> Karl
I empathize; audio on Linux is a difficult problem space in general.

That said, to effectively troubleshoot, please provide as much debugging 
information to the bug triagers as possible.  There is a nice script to 
gather this information for you and upload it to a pastebin.  Please see 
the script referenced from

Another course of action is to open an question.  
Be sure to attach the output.

Now, to un-muddy the problem space a bit.  Firstly, w{32,64}codecs isn't 
going to affect your sound driver.  If your speaker icon in GNOME's 
notification area has a red 'X' over it, it's not a codec problem but 
one of infrastructure.  Normally this boils down to two possibilities in 
recent Ubuntu releases (hardy and intrepid), namely either ALSA or 
PulseAudio is the culprit.  (In non-trivial circumstances, both ALSA and 
PulseAudio are to blame.)  Secondly, libflashsupport is obsolete in 
intrepid, so it's forcibly removed during a full upgrade process.

Perhaps a diagram for Ubuntu 8.10 will help.  We'll start at the top of 
the audio stack (where applications like your speaker icon reside).

ALSA userspace library
ALSA kernel driver
Sound hardware

One of the many problems with the "look online and attempt to use what's 
documented in twenty-five scattershot wikis, blogs, forum posts" 
approach is that you get a lot of misinformation (as you stated blithely 
earlier).  Quality debugging involves systematically and individually 
inspecting each of the five layers diagrammed above.  It's utter madness 
to try the buckshot approach.

The w{32,64}codecs bit is the applications layer.  Your issue needs to 
be debugged from the bottom of the stack upward.  I recommend not even 
bothering with further application tweaking until you've eliminated the 
middle two ALSA layers as problems.

A few of us hang out in #alsa and #ubuntu-audio-help on 
if that's preferable.

More information about the ubuntu-users mailing list