Problem with domain name server in intrepid

Kjetil Halvorsen kjetil1001 at
Fri Nov 14 16:45:28 UTC 2008

I finally seem to have solved this problem. I had ubuntu and kubuntu
installed on my
laptop, now I removed all the kde stuff. That by itself didńt solve
the problem. then I removed a lot of configuration files
in my home directory, and that solved the problem.


On Sat, Nov 8, 2008 at 14:36, Carl Friis-Hansen <ubuntuuser at> wrote:
>> add your local host name to the /etc/hosts file
>> ex.
>> 192.168.1.x   familien
> I think Kjertil's problem was the DNS servers, so I am not sure the above
> will help him.
> In the resolv.conf you just write as many lines you need:
> ////////////////////////
> nameserver
> nameserver yyy.yyy.yyy.yyy
> ////////////////////////
> However, yiu need to tell us how you connect. If you use DHCP, you
> shouldn't need this at all. Please explain more.
>> Carl Friis-Hansen wrote:
>>>> I just upgraded to intrepid, and there nis one problem:
>>>> I cannot set the dns from the gui, AND once set, the dns is forgotten
>>>> and has to be set anew
>>>> each time rebooting. Thsi is what I do to set dns:
>>>> 1) open a terminal window:
>>>> 2)
>>>> kjetil at familien:~$ cd /etc
>>>> kjetil at familien:/etc$ ls -l resolv.conf
>>>> lrwxrwxrwx 1 root root 31 2008-11-06 17:29 resolv.conf ->
>>>> /etc/resolvconf/run/resolv.conf
>>>> kjetil at familien:/etc$ cd /etc/resolvconf/run
>>>> kjetil at familien:/etc/resolvconf/run$ sudo pico resolv.conf
>>>> sudo: unable to resolve host familien
>>>> [sudo] password for kjetil:
>>>> In pico i write the line "nameserver"
>>>> and then writes out and exit
>>>> kjetil at familien:/etc/resolvconf/run$ sudo /etc/init.d/networking
>>>> restart
>>>> sudo: unable to resolve host familien
>>>>  * Reconfiguring network interfaces...
>>>>                                   [ OK ]
>>>> kjetil at familien:/etc/resolvconf/run$
>>>> Now internet works !
>>>> There must be a better way??
>>>> kjetil
>>>> (absolutely nothing I do from the gui works)
>>> Have they changed so much in Intrepid?  When I look at my resolve file,
>>> the permissions appears more appropriate and as you see, I am walking
>>> out
>>> to the Internet via a router in which all the needed name servers are
>>> listed. In that way, I only need to reference the router as name server.
>>> This has always worked:
>>> ////////////////////////////////////////
>>> carl at cjfh3:~$ ls -l /etc/resolv.conf
>>> -rw-r--r-- 1 root root 39 2008-11-08 17:17 /etc/resolv.conf
>>> carl at cjfh3:~$ cat /etc/resolv.conf
>>> search fiskeryd
>>> nameserver
>>> carl at cjfh3:~$
>>> ////////////////////////////////////////
>> --
>> ubuntu-users mailing list
>> ubuntu-users at
>> Modify settings or unsubscribe at:
> --
> Carl Friis-hansen
> --
> ubuntu-users mailing list
> ubuntu-users at
> Modify settings or unsubscribe at:

"Perhaps there is no such thing as unilateral power. After all, the
man 'in power' depends on receiving information all the time from
outside. He responds to that information just as much as he 'causes'
things to is an interaction, and not a lineal situation.
But the myth of power is, of course, a very powerful myth, and
probably most people in this world more or less believe in it. It is a
myth, which, if everybody believes in it, becomes to that extent
self-validating. But it is still epistemological lunacy and leads
inevitably to various sorts of disaster."
                 -- Gregory Bateson
Bob Hope  - "I love to go to Washington - if only to be near my money."

More information about the ubuntu-users mailing list