ekiga works, but vgrabbg gets green picture, on logitech orbit af sphere webcam

Martin Herren martin.herren at gmail.com
Wed Nov 12 11:32:29 UTC 2008


some times ago i had the same probleme with the Quickcam9000Pro. The
problem is all the grabber configured in Stopmotion don't work with
If your cam is a UVC device (most probably) and if it works for
example in luvcview, try the following:

Download, compile and installe uvccapture

Then under Stopmotion's config add a new grabber (under 'Video
Import'), called for example uvccapture. Configure it by putting

uvccapture -d$VIDEODEVICE -x640 -y480 -o$IMAGEFILE

in the 'Pre-poll command' field. Start and stop daemon should be left
empty. Of course you can adapt the x/y values if you want.

This way it should work with any uvc compliant cam...

Tell me if this worked for you, so i might ask the Stopmotion
developpers to add uvccapture to their default grabber list...

This solution is of course not optimal as of performance (there is
some lag)... a modified grabber based on mjpg-streamer running as a
daemon would be more performant put for the tests i did so far the
jpeg format given out by mjpg-streamer is not a correct jpeg and not
directly readable by Stopmotion... to be further investigated.

Good luck


On Wed, Oct 29, 2008 at 7:49 PM, Xn Nooby <xnooby at gmail.com> wrote:
> Hello,
> I have a Logitech Orbit AF Sphere webcam, and am trying to access it
> using the "stopmotion" app. Apparently the stopmotion program calls
> vgrabbj to grab an image from the webcam. I am running Ubuntu Desktop
> i386 8.10-RC1.
> When I run Ekiga, it is able to grab video from the Quickcam perfectly.
> When I run the "stopmotion" program, it only imports a green screen.
> When I vgrabbg manually, I get a single green picture.
> I've read a lot of messages in various forums, but nobody seemed to
> have the green picture problem. Since it works in Ekiga, I assume it
> should be able to work with stopmotion/vgrabbj.
> Any suggestions?
> -----
> h at hone:~$ lsusb
> Bus 008 Device 002: ID 046d:0994 Logitech, Inc. QuickCam Orbit/Sphere AF
> -----
> h at hone:~$ vgrabbj -s /dev/video0
> vgrabbj, Version 0.9.6
> Videodevice name: /dev/video0 (UVC Camera (046d:0994))
> Capabilities
> Type     : 1    Values can be looked up at videodev.h
> Channels : 1
> Audio    : 0
> MaxWidth : 960
> MaxHeight: 720
> MinWidth : 48
> MinHeigth: 32
> Current Settings:
> Brightness: 32896
> Hue       : 0
> Color     : 8224
> Contrast  : 8224
> Whiteness : 0
> Depth     : 16
> Palette   : YUYV (8)
> Width     : 800
> Height    : 600
> Chromakey : 0
> h at hone:~$
> -----
> h at hone:~$ vgrabbj -f test.jpg -d /dev/video0 -i svga  && eog test.jpg
> Reading image from /dev/video0
> There was no map allocated to be freed...
> h at hone:~$
> (results in green image)


More information about the ubuntu-users mailing list