problem with nvidia geforce2 mx200

Bram Kuijper a.l.w.kuijper at rug.nl
Fri May 30 19:03:31 UTC 2008


Hi all,

during the regular updates, my nvidia-glx package was updated last 
Wednesday. Since that moment, Xorg is not able to load the glx module 
anymore and only runs in safe graphics mode. I tried reconfiguring xorg, 
but to no avail. Any suggestions? See my configuration settings below.

thanks in advance,

Bram Kuijper




My /var/log/Xorg.0.log file says:

(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not 
found)


lspci says I have the following card:
$ lspci | grep -i nvidia
01:00.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 
MX200] (rev b2)

When I do lsmod | grep -i nvidia, it returns no kernel modules.
This is apparently the problem why xorg is not able to load glx modules.



However, my nvidia-glx driver is installed normally:
$ dpkg -l | grep nvidia
ii  nvidia-glx 
1:96.43.05+2.6.24.12-17.36                         NVIDIA binary XFree86 
4.x/X.Org driver
rc  nvidia-glx-dev 
1:96.43.05+2.6.24.12-17.36                         NVIDIA binary XFree86 
4.x/X.Org driver devel
rc  nvidia-glx-legacy                          71.86.04+2.6.24.12-16.34 
                           NVIDIA binary XFree86 4.x/X.Org 'legacy' dri
ii  nvidia-kernel-common                       20051028+1ubuntu8 
                           NVIDIA binary kernel module common files
ii  nvidia-kernel-source 
1:96.43.05+2.6.24.12-16.34                         NVIDIA binary kernel 
module source
ii  nvidia-settings                            1.0+20080304-0ubuntu1 
                           Tool of configuring the NVIDIA graphics driv


I also tried to get my graphics card working with the EnvyNG tool. It 
installed nvidia-glx-new next to nvidia-glx, but rebooting after that 
still did not solve the problem.

Furthermore, my xorg.conf is in pastebin:
http://pastebin.com/m710456a0

strangely, sudo dpkg-reconfigure xserver-xorg only asks for my keyboard 
settings, but stops straight after that and does not continue upon video 
settings. Very strange.




More information about the ubuntu-users mailing list