USB Drive sometimes auto mounts as read-only

Tom coffindvm at idabelok.net
Wed May 14 22:47:31 UTC 2008


On Sat, Apr 26, 2008 at 04:34:42PM -0400, Niels Andersen wrote:
> ---------- Forwarded message ----------
> | My USB Drive sometimes auto mounts as a read-only file system on Ubuntu 7.10
> i386 desktop.
> |  This does not happen frequently, but when it does, it means I can't update
> any files on the drive.
> |  How do I switch it to a read-write file system?  Is there something I can do
> to keep it
> | from being mounted as read-only?
> 
> | I have tried unmounting it and inserting it into another USB port, with the
> same results.
> |  I am going to reboot my desktop  to see if I can |  resolve this issue.  If
> that fails, I
> | intend to copy all the files off the USB drive, format it (as FAT32), and
> then restore the files.
> 
> The reboot did not resolve the issue.  Next, I will try copying the files from
> the USB drive,
> reformat it, and then put the files back on.
> 
> Niels

This probably wont help, but I had similiar problem with usb memory stick.  I 
had  default in my fstab as an option.  According to manpage default includes 
nouser so user cant mount.  I removed the default option and that solved the problem.
I realize you are talking auto mounting and my comments may not apply. The 
distro that was involved was not ubuntu.

Tom




More information about the ubuntu-users mailing list