Hibernation woes

Ted Hilts thilts at mcsnet.ca
Wed May 7 18:20:00 UTC 2008

Paul S wrote:
> Keith Clark said the following on 05/04/2008 11:12 PM:
>> I just tried to put my desktop computer into hibernation by pressing the
>> half moon key as I would have done in XP.  All seemed well, as the
>> computer shut itself down in a matter of 10-15 seconds.
> It takes about 40 sec's here .. the time is required to copy all the 
> information on open programs onto a file in your swap.
>> Then, I tried to restart it by hitting the power button, like I would
>> have done in XP.  Well, the system churned away and churned away.  The
>> cursor would respond erratically.  Finally a password window came up and
>> I entered my password.  It accepted it and a black screen came up.  All
>> this time the hard drive is going crazy with activity.  This went on for
>> about 15 minutes when I finally shut it down and restarted it.
> It takes about the same time as a reboot.  When it comes up the 
> (k)ubuntu splash screen progress bar freezes and disk activity is 
> constant because it's reading and starting all the app's from the file 
> in swap.
>> What was going on here?  Does hibernation work?  I thought it would be a
>> faster way compared to the shut down and reboot option.
> I don't think it's faster, but yes, it works "most" of the time here.  I 
> can't get repeated hibernations with compiz, so compiz is off for now 
> (Menu => Appearance => Desktop Effects => none).
> It also depends on which video card you have and which driver.
> regards,
I also, along with some others in the list, have had problems with 
"hibernation". At first it worked but complained during power up that it 
did not work -- but it did! Now, since I have been extensively using VNC 
it won't hibernate at all. When it did work (before using VNC) it 
complained about 2 things, and now it fails and brings up a flat 
rectangular grey box asking for my password after which it resumes from 
where it left off. I tried looking at the bash or bash like files that 
control "hibernate" but I could not figure it out. The one thing that is 
now different is that it seems to fail after not being able to find a 
"swap" area. It seems to be looking for the swap area (probably for 
temporary storage). Also, my machine is a dual boot right now and that 
might have something to do with the overall problem. Who knows.

I really like Ubuntu but maybe it is progressing too fast as a 
distribution and not enough testing has been involved. In my opinion the 
hibernation function has not been comprehensively tested or the "bug" 
would not occur -- and it is certainly a bug! Somewhere in what I have 
experienced lies that bug and it could even be complicated by the 
so-called power up, power down settings.

I try to read the Ubuntu list for solutions but so far the hibernate 
problems seem to get dismissed as a black hole that no one wants to fall 
into -- maybe I have missed something as I get several hundred emails a 
day and have time to look at just a few. But hibernate as a problem 
impacts me and so I am very interested in your problem.

Sorry that I cannot give you any concrete solutions but maybe you will 
now know that this is a serious problem for some users. It seems that it 
either works or it fails and it seems that this function fails for many.

Thanks, have a nice day anyway, Ted.
PS: I will watch you thread and see if you get a solution that works. 
Let me know if you do.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20080507/2436f0be/attachment.html>

More information about the ubuntu-users mailing list