error accessing NTFS partition

John Toliver john.toliver at
Fri Mar 28 19:05:36 UTC 2008

Has it ever been accessed by a windows OS after he nuked his original
windows installation?  Even though Ubuntu handles NTFS the
implementation is still new.  I notice that when I have to power down
my XP OS by hitting the reset button, and then instead boot into
Gutsy, I won't be able to access my NTFS partition.  When I reboot XP
and then do a proper shutdown, that is when I can then access the
partition.  It's got something to do with the journaling feature of
NTFS and needing to have the OS properly close the journal as part of

Solution might be to pull the drive out if possible, put it into
another installation of XP(or Vista) and then let the OS either
shutdown properly closing the partition or he might even be able to
just stop the drive and remove it instead of shutting down the
machine.  Try this if you haven't already.

On Fri, Mar 28, 2008 at 11:28 AM, Wade Smart <wadesmart at> wrote:
> 03282008 1015 GMT-6
>  A friend of mine has a issue with access a ntfs partition.
>  It was originally a duel boot machine with three partitions.
>  1 was ntfs for windows
>  1 was ntfs data for windows
>  1 was for ubuntu.
>  He deleted the windows partition but still have many GB of data in the ntfs
>  partition.
>  This is the fstab output:
>  fstab output
>  # /etc/fstab: static file system information.
>  #
>  # -- This file has been automaticly generated by ntfs-config --
>  #
>  # <file system> <mount point> <type> <options> <dump> <pass>
>  proc /proc proc defaults 0 0
>  # Entry for /dev/hda1 :
>  UUID=163cc188-1844-4b1c-9df1-0fc25fea05b0 / ext3
>  defaults,errors=remount-ro 0 1
>  # Entry for /dev/hda5 :
>  UUID=f8db8b78-efae-448c-bf3e-3bda5b157c88 none swap sw 0 0
>  /dev/hdc /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
>  /dev/hdd /media/cdrom1 udf,iso9660 user,noauto,exec 0 0
>  /dev/fd0 /media/floppy0 auto rw,user,noauto,exec 0 0
>  He followed several posts on the ubuntu forums for ntsf-3g and ntfsfix command.
>  Neither worked - or worked for long.
>  He had access to the ntfs partition but when he tried to create a new folder he
>  received the error "Unsupported Operation".  Apparently at some point he got it
>  working again but now is getting the same error and this new one - "Not enough
>  space to extend mft data" though he does still have 45gb of drive space left on
>  that partition.
>  He is using Gutsy.
>  He also said that he has a external drive that is usb and it is also ntfs and
>  that he can access it.
>  Wade
>  --
>  ubuntu-users mailing list
>  ubuntu-users at
>  Modify settings or unsubscribe at:

Patience yields far greater results than brute force or rage ever
could so's just life !!!

More information about the ubuntu-users mailing list