Ubuntu not using the swap partition

Bob McConnell rmcconne at lightlink.com
Wed Mar 26 01:29:38 UTC 2008


Ioannis Vranos wrote:
> OS: Ubuntu 7.10 x86.
> 
> 
> During installation I had created a partition named /hdc1 for swap, but
>  Ubuntu is not using it:
> 
> 
> john at john-desktop:~$ df -h
> Filesystem            Size  Used Avail Use% Mounted on
> /dev/hdc3             292G   13G  265G   5% /
> varrun                506M  132K  506M   1% /var/run
> varlock               506M     0  506M   0% /var/lock
> udev                  506M  104K  506M   1% /dev
> devshm                506M     0  506M   0% /dev/shm
> lrm                   506M   34M  472M   7%
> /lib/modules/2.6.22-14-generic/volatile
> /dev/hdc2             942M   35M  860M   4% /boot
> john at john-desktop:~$
> 
> 
> 
> root at john-desktop:~# fdisk /dev/hdc
> 
> The number of cylinders for this disk is set to 38913.
> There is nothing wrong with that, but this is larger than 1024,
> and could in certain setups cause problems with:
> 1) software that runs at boot time (e.g., old versions of LILO)
> 2) booting and partitioning software from other OSs
>    (e.g., DOS FDISK, OS/2 FDISK)
> 
> Command (m for help): p
> 
> Disk /dev/hdc: 320.0 GB, 320072933376 bytes
> 255 heads, 63 sectors/track, 38913 cylinders
> Units = cylinders of 16065 * 512 = 8225280 bytes
> Disk identifier: 0x99999999
> 
>    Device Boot      Start         End      Blocks   Id  System
> /dev/hdc1           38793       38913      971932+  82  Linux swap / Solaris
> /dev/hdc2   *           1         122      979933+  83  Linux
> /dev/hdc3             123       38792   310616775   83  Linux
> 
> Partition table entries are not in disk order
> 
> Command (m for help):
> 
> 
> 
> Any ideas on how to make Ubuntu use it?
> 
> 
> 
> Thanks,
> 
> Ioannis
> 

What does free tell you? The swap partition shows up under memory usage 
not disk usage.

Bob McConnell
N2SPP




More information about the ubuntu-users mailing list