Gutsy Upgrade problem

Rick Knight rick_knight at
Wed Mar 19 15:05:07 UTC 2008

>> NoOp,
>> I ran the command as you suggested, update-initramfs -k 
>> 2.6.22-a4-generic -u, and checked the time and date of 
>> /boot/initrd.img-2.6.22-14-generic and it looks like the command took. I 
>> rebooted and still go the BusyBox prompt and my hard drive are not 
>> present. My USB mass storage device is OK and my ZipDrive is visible, 
>> just no hard drives ( have 2, linux is on /dev/hdb). Anything else you 
>> can suggest?
>> Thanks,
>> Rick
> I presume you mean:
> sudo update-initramfs -c -k 2.6.22-14-generic
>> I've used blkid to verify the uuid is correct. I've edited
>> /boot/grub/menu.lst and /etc/fstab to use drive path (/dev/hdb5 &
>> /dev/sdb5) instead of uuid.
> You might want to relook at your fstab - they should be sdb vs hdb. Here
> is a copy of mine:
> # /etc/fstab: static file system information.
> #
> # <file system> <mount point>   <type>  <options>       <dump>  <pass>
> proc            /proc           proc    defaults        0       0
> # /dev/sda1
> UUID=<myuuid> /     ext3    defaults,errors=remount-ro 0       1
> # /dev/sda5
> <myuuid> none   swap    sw              0       0
> /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
> /dev/scd1       /media/cdrom1   udf,iso9660 user,noauto     0       0
> /dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
> # /dev/sdb1
> /dev/sdb1    /media/windows ntfs  iocharset=utf8,umask=000  0    0
> Note: sdb1 is a dual boot drive for windows. No UUID works, but
> eventually I'll get around to putting a UUID there.
> If all else fails, you can try substituting the UUID temporarily and use
> /dev/sda1 & /dev/sda5 to see if you can boot.
> My grub menu.lst on this machine looks like this:
> title		Ubuntu 7.10, kernel 2.6.22-14-generic
> root		(hd0,0)
> kernel		/boot/vmlinuz-2.6.22-14-generic root=<myuuid> ro quiet splash
> initrd		/boot/initrd.img-2.6.22-14-generic
> I'd also try using the alternate CD and select "rescue a broken system"
> + options.
> Other than that, you'll need Nils...

Yesterday I ran the command as "sudo update-initramfs -k 
2.6.22-14-generic -u" and then rebooted. No change, still boots to Busy 
Box prompt. Then I ran the command again like this "sudo 
update-initramfs -c -k 2.6.22-14-generic" and again rebooted. Same 
thing, Busy Box shell and a message indicating my drives can't be found.

I've studied my /etc/fstab and it looks correct. I've substituted the 
drives UUID with the path, both /dev/hdb5 and /dev/sdb5, modifying 
/boot/grub/menu.lst to match. Neither works and in fact when I use 
/dev/sdb5 grub can't find the boot loader at all, maybe this is part of 
the problem. I have never been able to use /dev/sdb drive spec, only 
/dev/hdb even on Feisty. My notebook and my desktop at work were both 
using /dev/sdx but my desktop at home would only use /dev/hdx.

Don't know if they'll help, but I'm attaching my fstab and menu.lst

Any other suggestion?

Thanks, Rick
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: fstab
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: menu.lst
URL: <>

More information about the ubuntu-users mailing list