Grub and ubuntu, SOLVED

Karl Larsen k5di at
Sun Mar 16 15:45:31 UTC 2008

Karl Larsen wrote:
> Tony Arnold wrote:
    It appears that no-one yet understands how to change a UUCP label 
and I sure don't. I can make a plain label with swapon and such but I 
dislike label's. They hide the real situation which got me into the 
problem I had. So I fixed it.

    Here is the repalacment for the silly ubuntu label in fstab:

old: UUID=a9c1cb61-ddfd-44f6-88b0-6dc976daf9ca /               ext3    
defaults,errors=remount-ro 0       1

new:/dev/hda8          /  ext3   defaults,errors=remount-ro 1       1

This works very well.

    The same changes to menu.lst has my system working fine now. I do 
suggest everyone replace the long weird labels with just the real thing 
as I did.

title           Ubuntu 7.10, kernel 2.6.22-14-generic
root            (hd0,7)
kernel          /boot/vmlinuz-2.6.22-14-generic root=/dev/hda8 ro quiet
initrd          /boot/initrd.img-2.6.22-14-generic

title           Ubuntu 7.10, kernel 2.6.22-14-generic (recovery mode)
root            (hd0,7)
kernel          /boot/vmlinuz-2.6.22-14-generic root=/dev/hda8 ro single
initrd          /boot/initrd.img-2.6.22-14-generic

    At least now I know what is working :-)



	Karl F. Larsen, AKA K5DI
	Linux User
   PGP 4208 4D6E 595F 22B9 FF1C  ECB6 4A3C 2C54 FE23 53A7

More information about the ubuntu-users mailing list