cdrom/dvd drive & hdparm

Ed Jabbour ejbr at att.net
Sat Mar 8 01:46:17 UTC 2008


I'm having problems with my dvd drive.  I'll skip the details as I'm not 
seeking help on what may be a hardware problem.  Just if anyone has a minute 
to review the following and let me know if there's anything wrong with these 
settings:

sudo hdparm /dev/hda

dev/hda:
 IO_support    =  1 (32-bit)
 unmaskirq     =  1 (on)
 using_dma     =  1 (on)
 keepsettings  =  0 (off)
 readonly      =  0 (off)
 readahead     = 256 (on)
 HDIO_GETGEO failed: Inappropriate ioctl for device
=====================================
sudo hdparm -I /dev/hda

/dev/hda:
ATAPI CD-ROM, with removable media
        Model Number:       TSSTcorp CDDVDW TS-L632N          
        Serial Number:
        Firmware Revision:  0503
Standards:
        Supported: CD-ROM ATAPI-3 -4 -5 -6 -7
Configuration:
        DRQ response: 50us.
        Packet size: 12 bytes
Capabilities:
        LBA, IORDY(can be disabled)
        DMA: mdma0 mdma1 *mdma2
             Cycle time: min=120ns recommended=120ns
        PIO: pio0 pio1 pio2 pio3 pio4
             Cycle time: no flow control=383ns  IORDY flow control=120ns
Commands/features:
        Enabled Supported:
           *    Power Management feature set
           *    PACKET command feature set
           *    DEVICE_RESET command
           *    NOP cmd
HW reset results:
        CBLID- below Vih
        Device num = 0 determined by CSEL






More information about the ubuntu-users mailing list