Installing devel packages for SVN

Dotan Cohen dotancohen at gmail.com
Fri Mar 7 15:21:35 UTC 2008


On 07/03/2008, Nils Kassube <kassube at gmx.net> wrote:
> Dotan Cohen wrote:
>  > How does one install the devel packages for installing apps
>  > (specifically in this case, Digikam) from SVN? Digikam needs libqt
>  >
>  > >=3.3.x however running "apt-get install libqt" did not find anything.
>  >
>  > I'm on Ubuntu 7.04. Thanks in advance.
>
>
> Well, I don't have 7.04 installed, but for both 6.06 and 7.10 the output
>  is the same:
>
>  ~/ > apt-cache search libqt|grep 'Qt3 header files'
>  libqt3-headers - Qt3 header files
>
>  I suppose, that's what you are looking for.

Thanks. After installing libqt3-headers I tried to install Digikam
from SVN but this is what I get:
...snip...
checking for Qt... configure: error: Qt (>= Qt 3.2 and < 4.0) (library
qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!
feisty at feisty-laptop:~$ tail libs/config.log
#define SIZEOF_SIZE_T 4
#define SIZEOF_UNSIGNED_LONG 4
#define HAVE_VSNPRINTF 1
#define HAVE_SNPRINTF 1
#define HAVE_LIBZ 1
#define HAVE_LIBPNG 1
#define HAVE_LIBJPEG 1
#define HAVE_LIBPTHREAD 1

configure: exit 1
feisty at feisty-laptop:~$

Am I missing something obvious?

Dotan Cohen

http://what-is-what.com
http://gibberish.co.il
א-ב-ג-ד-ה-ו-ז-ח-ט-י-ך-כ-ל-ם-מ-ן-נ-ס-ע-ף-פ-ץ-צ-ק-ר-ש-ת

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?


More information about the ubuntu-users mailing list