C complier - PSPP

Tim timfrost at xtra.co.nz
Sun Jun 15 03:57:29 UTC 2008

On Sat, 2008-06-14 at 19:40 -0700, Sam Albers wrote:
> > I am trying to install PSPP (0.6.0) a statistics package in Ubuntu.
> > However, I can't even make it past the configure stage as I get as
> error
> > message reading "configure: error: C complier cannot create
> executable".
> >

> Thanks for the help. I tried installing it earlier using synaptic.
> That didn't seem to work. No application appeared in the usual places
> (i.e. Applications drop down menu) and a search for PSPP on the file
> system revealed no executable files. So I tried installing it manually
> using the terminal. That is where I ran into the configure issue.
> Perhaps I am doing something wrong with the synaptic install. I've
> tried re-installing it several times but that doesn't seem to have any
> effect. Sorry if this is extremely rudimentary and I am missing the
> obvious. Once again, thanks for your help.

The menu system depends on having a file installed
in /usr/share/applications to describe the new application.  Note that
this makes more sense for a graphical application than for a program
that runs in a terminal.

It appears that the pspp package (version 0.4.0) in the repository for
hardy installs the binary in /usr/bin/pspp, and is a command-line
program, rather than having a graphical interface.  This means that you
need to run it from a terminal session.


More information about the ubuntu-users mailing list