8.04 networking seems awfully broken.

Peter Garrett peter.garrett at optusnet.com.au
Thu Jul 24 18:57:57 UTC 2008

On Thu, Jul 24, 2008 at 06:10:02PM +0000, Grant Edwards wrote:
> On 2008-07-24, Derek Broughton <news at pointerstop.ca> wrote:
> > Grant Edwards wrote:
> >
> >> I found recipes in forum postings.  Was the installer supposed
> >> to do something?
> >
> > No.  The "hardware drivers manager" does (jockey-kde in KDE and jockey-gtk
> > in Gnome), _after_ you start your desktop.
> I didn't see anything.  After I noticed that wan0 wasn't
> associating no matter how many times I ran the network-manager,
> I started sifting through the sysmem log and found an error
> message from the bt43 driver saying that it couldn't find a
> firmware file.  After some googling through the forums, I found
> the recipe for download the firmware and the extractor and
> generating the required .fw files.
> > Maybe not 30 - but in my case it did require some time before
> > Jockey told me about the required firmware.
> Maybe I didn't wait long enough, but it probably took me at
> least a hour of looking at system logs and googling before I
> had the firmware files installed.  Nothing popped up during
> that time.


First hit:


Two solutions:

sudo apt-get install b43-fwcutter 



I have a Broadcom  bcm 4306 on an iBook G4 - it worked as soon as I 
installed the cafuego package. It's a dual boot - with Debian Sid. On Sid it 
worked as soon as I installed b43-fwcutter, with wpa encryption set 
up in the router/AP and the nm-applet config.

I'm not saying it's obvious, and of course you need a wired connection 
to grab either of the above, but the packages are not really hard to 
find, and you certainly don't need to compile anything.


"INX Is Not X" Live CD based on Ubuntu 8.04 : http://inx.maincontent.net
Screenshots slideshow: http://inx.maincontent.net/album/1.png.html

More information about the ubuntu-users mailing list