8.04 networking seems awfully broken.

Grant Edwards grante at visi.com
Thu Jul 24 14:28:41 UTC 2008


On 2008-07-24, Karl Larsen <k5di at zianet.com> wrote:
> Grant Edwards wrote:
>> I keep reading reviews about how Ubuntu "just works", so I
>> decided to give it a try by installing Ubuntu 8.04 as an
>> alternative OS on a laptop belonging to somebody who normally
>> uses Windows, but would be willing to give Linux a try.
>>
>> I'd have to say that the networking support seems to quite a
>> mess (at least compared to other distros I use):
>>
>>   
>     Which other distros have you loaded on this computer?

None.

>>   1) There's a daemon called avahi-autoipd that keeps starting
>>      up and f*&king up the network configuration.  I configured
>>      the interfaces to use DHCP.  That means that if there's no
>>      response from a DHCP server, then keep trying until there
>>      _is_ a response from a DHCP server.  I don't recall
>>      checking a box that said "only use DHCP until you get
>>      bored and want to pull an IP address out of your ass".
>>
>>   
>     You seem to have an issue with the loader software. Was it too
>
> simple for an expert like yourself? As I recall the network part of the 
> loader was preset and you just hit Enter and go on.

I've no clue what you're talking about.  Other distros (e.g.
Gentoo) typically provide "firmware" packages that alleviate
the need for the user to manually download files, binary
extracters, etc.

>>      I've never seen even a single network that uses link-local
>>      IP discovery.  I'm sure it's cool in theory, but why
>>      that's enabled by default is beyond understanding.
>
> Well don't stop there. Explain what link-local IP discovery
> is? I didn't know Hardy had any.

Google it, dude.

>>      Disabling it in the services applet doesn't help either --
>>      you've got to fire up a terminal window and apt-get remove
>>      the package.
>>   
>     Now that is a really stupid thing to do!

Why is that?  It's seemed (according to the forums) to be the
only easy way to prevent the autoipd from seizing control of
interfaces.  And it seems to have sovled that problem.

>>   2) Firmware for the the wireless chipset had to be manually
>>      downloaded, extracted (using a utility that had to be
>>      built from a source tarball), and copied into
>>      /lib/firmware.
>
>     Which chipset would that be?

Broadcom 4306

>>   3) I've configured the wireless interface to use WPA, but
>>      wpa_supplicant doesn't start on boot-up.  You've got to
>>      fire up a terminal and do "/etc/init.d/network restart" to
>>      get wpa_supplicant running.
>
>     Yes and that is really hard to do isn't it. Poor boy.

It's something that other distros seem to be able to do
automatically on startup.

>>   4) Once wpa_supplicant is running, the network management
>>      applet seems incapable of configuring wpa_supplicant with
>>      the password. It's unable to associate until one fires up
>>      a terminal, starts wpa_cli, and sets the password
>>      manually.
>
> Gosh a password too? What kind of WiFi are you stealing?

What is your damange?  It's my own network.  Entering the
password via the network config applet doesn't work.  Entering
it via wpa_cli does.  That means the network manager applet is
broken.

I'm not going to ask a lifelong Windows user to spend a
half-hour with a bash prompt typing commands everytime she
want's wireless networking to start.

> Maybe this is the whole problem. If you had just loaded Hardy
> and rebooted and did the little easy things and then let it
> just sit turned on for 30 minutes, it might have just started
> working. Mine did.

Having to wait 30 minutes for a network interfaces is _not_
"working".

>> End result: a waste of about 8 hours of my time and a black eye
>> for Linux.
>
> From my experience with Hardy it had zero problem with the
> network.  On this computer it found the ethernet card and
> worked. On my laptop it loaded and after a few minutes it
> discovered WiFi and worked.

Well bully for you.  I found plenty of other postings in the
Forum complaining about the above problems, so it's not just
me.

-- 
Grant Edwards                   grante             Yow! I invented skydiving
                                  at               in 1989!
                               visi.com            





More information about the ubuntu-users mailing list