hardy, and usb drives, does anyone have one that works?

Bart Silverstrim bsilver at chrononomicon.com
Mon Jul 14 12:32:36 UTC 2008

Karl Larsen wrote:
> Nils Kassube wrote:
>> Karl Larsen wrote:
>>> Jim Smith wrote:
>>>> steve wrote:
>>>>> I have 2 usb hard drives sitting collecting dust because I cannot
>>>>> figure out how to read and write to them.  1 is 80 gig seagate, and
>>>>> the other is 160 gig fantom.  Both HAVE worked on ubuntu in the
>>>>> past, from 5.x right up through gutsy.
>>>     Since nothing seems to work here is a sure fire method I had to use
>>> once.
>> [snipped procedure to repartition and format]
>> Karl,
>> in the text you quoted, Steve wrote that it worked until Gutsy. There is 
>> no reason to believe it would help to repartition and format the drives. 
>> Furthermore it would have been nice to point out that your procedure will 
>> wipe out any data still on the drives.
>> Nils
>     It should be known to anyone that changing the file system will wipe 
> out any previous data. The first words seem to indicate he has a problem 
> with Hardy. That could be true but if true it is a big problem with many 
> components of Hardy.

I doubt it. I use USB drives all the time under Hardy. I had problems 
during one upgrade batch where it wasn't detecting the drives right away 
at startup, and one daemon was coming up at first login with an error 
about not starting (I think it was avahi). Even then I would log out and 
wait a bit and log back in, and if that didn't work, unplug the drives 
and plug them back in until they were recognized.

A couple weeks later another set up updates seemed to fix that problem.
Hardy before that didn't have that problem on my system.

If *no* USB drives are working for him I'd suspect cables or a problem 
with the hardware in the CPU; has he tried other ports and/or a 
replacement cable? Another possibility depends on whether he's using a 
USB hub; if something plugged in to that needs more power and the hub 
isn't being externally powered, there's all sorts of weirdness that can 
result...drives dropping, data dropping, devices not working or 
glitching out...

I haven't been following the thread, but these are some other 
suggestions. My last one before bowing out would be to boot with 
liveboot CD's of Ubuntu and other distros (since they won't screw up his 
hard disk) and plug in the USB devices to see if they're recognized. If 
it's a software problem with his configuration the devices should pop 
right up, since these should be known-good configs. If they don't, it's 
hardware-scopin' time.

Was this any help?


More information about the ubuntu-users mailing list