xfs home directory went south

David Fox dfox94085 at gmail.com
Fri Jul 11 01:52:57 UTC 2008

Guys, I have a real problem.

I've been running Ubuntu Hardy successfully for about a month and 1/2
now ever since I built my new box over Memorial Day weekend.

Something really strange must have happened today because my box,
which has been doing really well 24/7, was completely locked up when I
came home from work. I think perhaps the box overheated. I tried to
reboot, the first time I couldn't get past the bios so I turned it off
and waited a bit. The second time I tried to boot I got a boat load of
kernel panics - which likely is a sign of overheating as well, so I
shut off again, waited a little bit more. When I finally was able to
boot into ubuntu, I got a warning that flashed on the screen saying my
/dev/sdc3 (xfs, home partition) was corrupt and refused to mount it.

I tried to remount it a few times, and did an xfs_repair -L on the
filesystem and it seems to have brought some of it back, but not all.
I was able to bring back most of it from my month old backup of home
that I still have on another HD. But much of the filesystem seems to
be gone - any new settings and things like what was in .mozilla are
gone although those could be recreated as well as some source code
directories (those were easily gotten back with svn checkouts).

However, some files that I was saving including some 30 gigs of AVIs
are unreachable. Not only that, the "free" count of the filesystem
seems to hint those files are there.

I'm new to xfs so I need a bit of hand holding. Is it too late to fix
the system? I figure if I do another xfs_repair it'll hose it even


More information about the ubuntu-users mailing list