Segfaults in weird places after aptitude update && aptitude upgrade on clean alternate gutsy install

Brian McKee brian.mckee at
Mon Feb 25 18:17:57 UTC 2008

On Thu, Feb 21, 2008 at 11:19 PM, Brian McKee <brian.mckee at> wrote:
> I've done this three times now, so I know it's not me :-)
>  After an update my system has weird segfaults, X is unusable.

Well, I'm going to wrap this thread up with a completely unsubstantiated

Don't mix ext3 + xfs with /boot not under LVM and / under LVM

Something in there just doesn't work - and it might be the installer....

I moved the drive to completely different hardware and tried again, and got
completely different issues - all weird enough to make me think it's still file
corruption of some sort.

I then tried to do an 'all LVM' setup both manually and using the option on the
installer disk, and the partition software in the installer seems incapable of
removing it's own previously created partitons.

In the end on a whim I chose 'LVM with encryption' and it worked fine.

I dunno - I've wasted a lot of time futzing at this and still can't put
together info good enough to call a bug report, so I'm just gonna wash my hands
of the whole mess.

Thanks to all who contributed.


More information about the ubuntu-users mailing list