Partition Reorganization / unsuccessfull ;-(

i-ubux at i-ubux at
Wed Feb 20 00:09:54 UTC 2008

Hi Nils, thanks for your prompt reply.
I quote directly into the text following:

> i-ubux at wrote:
>> With GParted and the Super Grub Disk I was able to recognize and use
>> either the old (sda2) or the new (sd7) Ubuntu 7.1 installation. ;-)
> What I don't understand - sorry, I didn't ask before: What for do you need
> that supergrub disk? If you have installed the system, you should somehow
> be able to boot without extra disk / cd.

Too often in earlier times I got boot problems and
so I wanted to have a tool helping me to get back to track if needed.
I heard of it while discussing, googling and preparing for my Partition
reorganization !

>> After creating one more "copy" with GParted in a separate partition and
>> assuming that everything will work now ...
>> ... I erased the UN-needed sd2-partition and like Derek wrote:
> You should have tested that it works - just assuming it works is more like
> playing Russian roulette. However, now it is too late for testing.

Of course i had tested it working not only ONE time ...
... few times. I was able to boot from both the installations ...
... as long the original sda2 was present ! ;-)

>> Since Sunday I am trying and trying my frustrating efforts to
>> get my Ubuntu back running or save all it's "personal" data:
> To save your data, I would suggest to us the Ubuntu Live CD. From the Live
> CD you can mount the relevant partitions and copy the data preferably to
> another machine.

For the very first time I had tried this yesterday too and
as a total Linux Greenhorn I was unable to get done how and what's needed.
I really do appreciate some more specific guidance here: TIA ! ;-)

>> I am sure (now, new) sd3 is a ext3 partition.
>> Sometimes I see it displayed as ext3sf !?!?
>> How comes ??
> Where do you see it as ext3sf? Can you mount the partition from a Live CD?
> If so, open a terminal and use the mount command to find out what file
> system it is. But I suppose it is not ext3sf but ext3fs and ext3 is the
> same as ext3fs - with fs being the abbreviation for "file system".

Seems I been too stressed / tired: Typo !
Should have been: Sometimes I see it displayed as ext2fs !!

>> Well, Super Grub Disk always confirms a positive result but
>> restarting the system always ends with
>> Error 22: No such partition !
>> Of course it still points to sda2 (hd0,1) which is wrong
>> because it shall be hd0.2 !?
> I'm not sure what happens here because I never used the super grub disk.
> But I think it restores your MBR to make it boot with grub. Then you
> should be able to boot without the super grub disk. At the boot prompt
> you could edit the kernel and initrd lines to point to the right
> partitions. Of course that only works if you have a working installation
> on that partition. See <> for
> infos how to use the grub menu.

I may have a clue what's happening here and I am sure it has nothing to do
with the Super Grub Disk: It's more Linux specific !?

With my other OS'es only 5 mins after reinstallation and, without
reinstalling any SW, I am back to track !!! ;-D

Yes, I will study your link to GrubHowTo but
I am sure the problem is in sda3's menu.lst:
It still points to the wrong location ! ;-|

> If you really made a copy of a working partition to your sda3 partition,
> you should at least edit the /etc/fstab file of that partition (using a
> live CD). Otherwise you will not be able to boot, even if you got the
> command line correct in the grub menu.

I do pray too that the copy I made with GParted really works !

Just booted the system and noticed that Grub Boot Selector displays
as usual. After the given few seconds or with "Enter" it says:

Error22: No such partiton

Press any key to continue...

As from my point of view:
Grub is still around and working but somehow I doesn't
recognize nor accept sda3 as destination because
within my Linux the settings are still not matching !?

BTW: No problems to select Win XPP: Selected it boots & works. ;-)

As Linux / Ubuntu greenhorn I am really unable to crack and solve
my Linux / Ubuntu system's problems.

I really do appreciate very much to get enlightened ...
... how to get my sda3 with its Ubuntu back to track again !

I am quite confident we can get it but as old newbie I need an
experienced Linux "oldie's" support. ;-D

Once again: Thanks a lot and TIA for future assistance with
cheers, svobi

More information about the ubuntu-users mailing list