Fwd: Re: Fwd: No rt* modules on alternate cd: Was Alternate Gutsy CD-Debootstrap Error Installing Base System-Failed To Determine Code Name Of Release-Solved

Leonard Chatagnier lenc5570 at sbcglobal.net
Fri Feb 15 19:16:55 UTC 2008

--- Leonard Chatagnier <lenc5570 at sbcglobal.net> wrote:

> --- NoOp <glgxg at sbcglobal.net> wrote:
> > On 02/13/2008 09:26 PM, Leonard Chatagnier wrote:
> > > --- NoOp <glgxg at sbcglobal.net> wrote:
> > 
> > >> 
> > >> Give this a try:
> > >> 
> > >> Alternate CD: install in text mode, do not
> select
> > >> *any* network during
> > >> the install process, continue the install
> > *without
> > >> networking*, set up
> > >> networking after the install.
> > >> 
> > >> 
> > > Thanks for the come back, NoOp. However, that's
> > > exactly what I did. I presume you mean after the
> > > install and reboot which is what I did. What
> gets
> > me
> > > the most is there is no mention of wireless
> > networking
> > > that I find after 3 installs and when I boot up
> > only
> > > wired and dialup modem entries are shown under
> > > networking. Makes it difficult to set up a
> > wireless
> > > even if the drivers are in place. Are there any
> > > preferred mirrors to download the iso from? Is
> > there
> > > more than one version of gutsy(i386 version) to
> > choose
> > > from? BTW, the alt CD only recognizes my NIC.
> > There is
> > > no mention of the WMP54G in dmesg or anywhere.
> > > Reallly weird! Thanks for your help,
> > > 
> > 
> > Mirrors should all be the same.
> > http://www.ubuntu.com/getubuntu/downloadmirrors
> > 
> Thanks, one less worry.
> > Odd... when I installed my son's laptop with an
> > Dynex PCMCIA card in it
> > using the Alternate CD I seem to recall that it
> pick
> > up the device and
> > showed both the wireless and the built in nic.
> >
> > 
> > But that wouldn't help you with the rt* modules.
> > Perhaps the Ubuntu DVD
> > has what you are looking for. You can check what
> > files are included by
> > checking the .list file:
> > 
> > http://cdimage.ubuntu.com/releases/gutsy/release/
> >
> > 
> > You can do the same by checking the .list file for
> > the Alternate CD from
> > any of the mirrors, example:
> > 
> >
> > 
> Thanky so much. I'll check them all to see if the
> rt*
> mods are listed and maybe try out the alt DVD also
> as
> I'm trying out the 4th install and still find it
> hanging at certain spots in the install software
> portion which I don't think it should do.  Also
> trying
> the linux generic ipo the 2.2.22.-14 generic that I
> remember you saying was the only one that worked for
> you and your wifi card. I let the list know what
> happens.  Thanks for the needed help.
> Leonard Chatagnier
> lenc5570 at sbcglobal.net
I did solve this problem after 6 or more retries with
the alt gutsy i386 CD. I reburnt the CD several times,
at least 4 times to no avail. It just wasn't the CD
but it's programming and the way it interacts with my
Dell Dimensions XPS T450 with 384 MB ram and 8 gB HDD.
The alt CD gave only one error on the initial trial;
debootstrap error that I don't recall the entire
message but did mention in an earlier post. The
downloaded iso md5sum checked ok; the burnt disk
md5sum checked ok with the iso file and the disc
verified during burning. The issue may be do to using
the alt install CD on a different machine from the one
that burned the CD, a Gateway GT5656. I burned,
installed the 64 bit iso on that machine, the first
ever that I burned a CD, all without a hitch from
start to finish.
I can't find a problem on the i386 alt cd as I can
read it, install any software from it(which is how I
eventually solved the issue) but it just leaves some
parts of the "install software' section of the install
out and it's different on each install attempt, very
buggy I'd say. The rt61pci module was installed on the
first install that gave the debootstrap error yet
eventually installed the base system and apparently
the rest or most of the software but decided to
reinstall because of the error. The first trial used
the latest kernel on the cd. Later installs with the
same kernel did not have the rt61pci module in the
/lib/module dir on several attempts and after
reburning. I eventually used the low end Linux generic
kernel which contained the rt61pci module in the
/lib/module dir on all attempts, but some of the
software was never loaded on every attempt. The
missing software was different on every attempt which
is strange indeed. On the last install with the Linux
generic kernel, that I mad work, there was no
/etc/resolveconf dir nor an /etc/resolv.conf file on
my hard disk after completing the install. Also not
installed was Xorg, ubuntu-desktop nor
kubuntu-desktop(which I tried to install with
ubuntu-desktop using aptitude and showed no error
after aptitude completed. Well trying to remember all
that I had to instll manually is impossible; let's
just say that I got a base system install and very
little else. As it became obviously clear that no
matter what I do, I wouldn't get a complete error free
install, I just installed each program as I determined
what they were, manually from the quirky alt cd and
that's how it was solved.  I'm now fully up-to-date
except for some later kernels that I plan to install.
Never had an issue of this nature going all the way
back to my Debian days with the woody version. Most
frustrating experience.
Thanks to NoOp, Derec and others who helped me on this
And to anyone using the LinkSYS WMP54G v4.1 wifi card,
you do have to add "rt61pci" to /etc/modules and add
"blacklist mac80211" to /etc/modprobe.d/blacklist then
shutdown and pull the card if installed, followed by
rebooting then shutdown again, reinstall the card then
startup and hope you connect.  If not, and there
s nothing wrong in your wlan0 setup, a "sudo ifdown
wlan0" followed by "sudo ifup wlan0" usuall gets you
connected. Hope this helps you, the unexperienced newbie.

Leonard Chatagnier
lenc5570 at sbcglobal.net

More information about the ubuntu-users mailing list