hung boot process

Marius Gedminas marius at pov.lt
Thu Feb 14 13:00:17 UTC 2008


On Wed, Feb 13, 2008 at 04:37:12PM -0700, Bob Holtzman wrote:
> Please excuse the long post. I'm trying out Ubunt for the first time 
> and ...........
> 
> After deleting the OEM installation of 7.10 because I don't like 1 big 
> partition. I reinstalled and set up /, /boot, /usr and /home. The 
> installation appeared to go well so I shut down the box, changed the bios 
> to boot from the hard drive and continued to boot the system. Everything came 
> to a stop during loading grub and displayed error 15.

15 : File not found
    This error is returned if the specified file name cannot be found,
    but everything else (like the disk/partition info) is OK.

        -- http://www.gnu.org/software/grub/manual/grub.html#Stage2-errors

> A search for error 15 yielded:
> 
> 1. check rootline in grub.config --> locate *grub.config came up blank
> 2. reinstall grub w/ grub-install --> /boot initially was missing grub.
>    ran /sbin/grub-install and /boot/grub appeared but contained only
>    a device.map file
> 3. check /boot partition --> fsck -v /dev/sda6 showed it was clean 
> 4. check for /boot/grub/menu.list --> see no. 2 above.

If you can run grub-install, then you can also run update-grub to
generate a working menu.lst.

The installer should have done that for you.  I wonder if a separate
/boot partition didn't confuse it.  If you unmount the /boot partition,
do you end up with an empty directory, or are there any files left that
were hidden behind?

> I tried deleting all partitions and reinstalling a couple of times with 
> the same result.

(I tend to stick with one-big-partition.  No problems whatsoever.)

Marius Gedminas
-- 
The difference between Microsoft and 'Jurassic Parc':
In one, a mad businessman makes a lot of money with beasts that should be
extinct.
The other is a film.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20080214/ec064fb2/attachment.pgp>


More information about the ubuntu-users mailing list