must rmmod nvidia & modprobe nvidia to start X

Sven Richter sveri-list at
Tue Feb 12 00:11:42 UTC 2008

Hi Zach,

On Friday 08 February 2008 17:34:40 Zach wrote:
> I have a problem where X won't start at boot.  If I log into a
> terminal, and rmmod nvidia && modprobe nvidia, then X will run fine.
> As a hack, i have this added to the gdm init script.  This is working,
> but I'd like to solve the problem.
I experienced the same problem after the upgrade from feisty to
Briefly explained, after updating i tried out the drivers from
ubuntu, nvidia-glx-new, or something like that.
But they didnt work for me like i wanted, so i thought i removed
them and installed the binary drivers from nvidia.
Same thing happened to me, i had to rmmod nvidia and modprobe
nvidia after a reboot.

It didnt annoy me much, but after a while i had some time and fiddled
around with the drivers, removing, purging and reinstalling the binary
driver, and out of the blue it worked.
So far so good.

Saturday i broke my mainboard and got a new one, and because
i had one free day i wanted to install hardy on a software raid.
Said, Done, everything works fine.

I installed the binary driver from nvidia, and whoosh, the same problem
again, i have to rmmod nvidia and modprobe nvidia again to get X working
after a reboot.

Just a few seconds ago i removed nvidia-kernel-module, and tomorrow
i can tell you if X works without the procedure.

I believe that nvidia-kernel-module breaks the binary driver.

Maybe blacklisting the nvidia module could help too, but i didnt try out.


More information about the ubuntu-users mailing list