Linksys WMP54G Wireles Adaptor Wont Work; Or I Don't Know How To

Leonard Chatagnier lenc5570 at sbcglobal.net
Wed Feb 6 22:09:02 UTC 2008


--- NoOp <glgxg at sbcglobal.net> wrote:

> On 02/02/2008 08:36 PM, Leonard Chatagnier wrote:
> 
> > lspci shows "NETWORK CONTROLLER: RaLink
> RT2561/RT61
> > 802.11g PCI. I did a modprobe rt61pci and lspci
> shows
> > it to be installed.  I haven't pulled the card yet
> and
> > will wait on clarification first.  But on a
> restart
> > dmesg|tail only had bluetooth entries.  Dmesg|less
> had
> > some interesting items:
> > 
> > iwiwifi_rc80211_simple:unknown symbol
> > iwlwifi__sta_info_put(all one line)
> > There were 2 other similar entries with only the
> last
> > 2 words different.  The ending on one was
> sta_info_get
> > and ieee80211_rate_control_register. All hand
> > transcribed so didn't copy those.Then the last 2
> dmesg
> > entries were:
> > 
> > ADDRCONF(NETDEV_UP): eth0: link not ready
> > ADDRCONF(NETDEV_UP): wlan0: link not ready
> > 
> > No other dmesg related entries.  Hope it help as I
> > don't know what they mean or what to do about
> them.
> > Thanks for the help,
> 
> Links:
> 
> https://bugs.launchpad.net/ubuntu/+bug/34902
> 
> Seems like a lot of work. I'd try ndiswrapper first.
> Before doing so,
> I'd make sure that you have the latest drivers for
> your version:
> 
>
<http://www.linksys.com/servlet/Satellite?c=L_CASupport_C2&childpagename=US%2FLayout&cid=1166859843981&packedargs=sku%3D1150490054358&pagename=Linksys%2FCommon%2FVisitorWrapper&lid=4398154358B03&displaypage=download>
> 
> In case that link doesn't work - it linksys.com &
> WMP54G Downloads
> 
> These might help... or confuse the issue more:
> http://ubuntuforums.org/showthread.php?t=563547
>
http://www.gs1.ubuntuforums.org/showthread.php?t=653179
> 
> Good luck & hope you get it working.
> 
Sorry for the delay but been googling and installing
Ubuntu on a new computer.  Did find some more new
insite on the V4 of WMP54G wifi PCI card when I
reviewed the Ubuntu supported driver page:

https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsLinksys

V4 doesn't use the rt61pci module/driver but the
rt2500pci moodule. As suggested for the V4.1, I
blacklisted rt61pci and plan to place rt2500pci in
/etc/modules. Still getting the same errors after
blacklisting but am getting other errors relating to
mac80211 which i would also like to blacklist along
with related modules which lead to error on startup.
Involved modules are:

mac80211       cfg80211     rc80211_simple
rt2x00pci       rt2x00lib    rfkill
crc_itu_t      eeprom_93cx6

Are any of these modules critical to system operation
or to my wireless card working as I'd like to
blacklist all or any of them to troubleshoot?  The
rc80211_simple module gives errors immediately after
the card is recognized and irg 10 assigned on startup.
 These errors are the iwlwifi errors mentioned in the
orig post. There is a rc2500  module for 2.6.236-14
generic kernel but it is not autoloaded; never has. 
Is there a console command that will tell what the
rt2500pci dependencies are? Any answers or suggestions
are welcome.

Note to NoOp"  Read most of the links and decided the
fix is too much for my linux limited mind. Decided to
to try another supported card until I found the info
above that I want to try out. A solution involving
just module setup, if possible, would be an easier
solution, at least for me. I'm going to check it all
out as soon as I have more time.  Thanks and too the
OP for the ndiswrapper suggestion.

Leonard Chatagnier
lenc5570 at sbcglobal.net




More information about the ubuntu-users mailing list