X won't start at boot with NVidia driver

Sven Richter sveri-list at gmx.de
Tue Feb 5 07:55:09 UTC 2008

Am Dienstag 05 Februar 2008 01:50:35 schrieb Ed Jabbour:
> On Monday 04 February 2008 4:40 pm Sven Richter wrote:
> > Am Montag 04 Februar 2008 19:43:19 schrieb Ed Jabbour:
> > > Running kubuntu 7.10 on an HP laptop.  I downloaded the proper driver
> > > from the Nvidia site and it installed with no error messages.  I ran
> > > startx and no problems.  However, at a reboot, X would not start -
> > > screen not found. I edited xorg.conf to load the vesa driver and got X.
> > >  The NVidia driver will not run correctly until I delete a number of
> > > libnvidia .so files and a few others from the /usr/lib directory.  It
> > > then installs and startx works, but not at reboot.  The same process
> > > over and over.
> > >
> > > Any hints, pointers, etc appreciated.
> >
> > I had the same problem with the old nvidia binary 1.0x49 iirc.
> > After booting i had to kill kdm, rmmod nvidia and the modprobe nvidia
> > again.
> > Aftwards x could be started.
> > I assume i messed up some things cause i tried the drivers from
> > the repos.
> >
> > Then in installed the new binary driver 169.09 and the problem was fixed.
> Yes, that's the same run package I used.  I tried the nvidia-new-glx and a
> bunch of other stuff - that didn't work either.  So I ran the 169.09
> package, removed all the nvidia stuff manually, etc. as above.  I don't
> dare shut down this machine, though.   Should I have "nvidia" in
> /etc/modules?  From where are modules loaded at boot, anyway?

You could try out what i wrote above.
But i have to admit, it gets boring after a certain time, so
this is no real solution :D

Like Ed said, its generally not a good idea to delete files
Try to purge remove all nvidia stuff via aptitude, oder apt-get
and then reinstall the binary driver, this worked for me.

Sven Richter

More information about the ubuntu-users mailing list