X won't start at boot with NVidia driver

Ed Greshko Ed.Greshko at greshko.com
Tue Feb 5 01:00:16 UTC 2008


Ed Jabbour wrote:
> On Monday 04 February 2008 4:40 pm Sven Richter wrote:
>> Am Montag 04 Februar 2008 19:43:19 schrieb Ed Jabbour:
>>> Running kubuntu 7.10 on an HP laptop.  I downloaded the proper driver
>>> from the Nvidia site and it installed with no error messages.  I ran
>>> startx and no problems.  However, at a reboot, X would not start - screen
>>> not found. I edited xorg.conf to load the vesa driver and got X.  The
>>> NVidia driver will not run correctly until I delete a number of libnvidia
>>> .so files and a few others from the /usr/lib directory.  It then installs
>>> and startx works, but not at reboot.  The same process over and over.
>>>
>>> Any hints, pointers, etc appreciated.
>> I had the same problem with the old nvidia binary 1.0x49 iirc.
>> After booting i had to kill kdm, rmmod nvidia and the modprobe nvidia
>> again.
>> Aftwards x could be started.
>> I assume i messed up some things cause i tried the drivers from
>> the repos.
>>
>> Then in installed the new binary driver 169.09 and the problem was fixed.
> 
> Yes, that's the same run package I used.  I tried the nvidia-new-glx and a 
> bunch of other stuff - that didn't work either.  So I ran the 169.09 package, 
> removed all the nvidia stuff manually, etc. as above.  I don't dare shut down 
> this machine, though.   Should I have "nvidia" in /etc/modules?  From where 
> are modules loaded at boot, anyway?

When you have problems such as this the first place to look is 
/var/log/Xorg.0.log.  It will normally give you a good idea of what when 
wrong.  Not a great idea to delete files and such till you know the root 
cause.  But, maybe you looked in the log and just didn't post the errors...





More information about the ubuntu-users mailing list