Problem to make my camera to work

Peter Smerdon psmerdon at
Mon Feb 4 22:06:59 UTC 2008

Derek Broughton <news at> writes:

> Carlos Roballo wrote:
>> Hi All,
>>    I have a Toshiba U305-S7446 laptop. I installed Ubuntu 7.10 with all
>> updates two months ago. All worked well but the webcam. It has a Chicony
>> USB2.0 camera built-in. I searched at that time some forums and found no
>> solution.  Today I checked again and no updates.
>>    I really like Ubuntu and I cannot believe I will have to go back to
>> Windows (urghhhhh !!) because I cannot use my webcam.
> I can't believe it either - who really needs a webcam? :-)

Actually lots of people, when working out of town it's a nice thing to
be able to see loved ones as you chat.

> Please don't blame Ubuntu because you made the mistake of buying a computer
> with unsupported hardware.  Do your research before you buy!
> That said, you haven't given us enough information to help you.  Calling it
> a "Chicony USB2.0" camera tells us nothing.  What does lsusb show?
> -- 
> derek

My HP 9000 series laptop also has this cam but I cannot get it to work:
Bus 004 Device 002: ID 04f2:b023 Chicony Electronics Co., Ltd

I have tried loading the uvcvideo, compat_ioctl32 videodev modules which
apparently are the ones I need but camorama still says could not connect
to /dev/vide0 .

I then installed `webcam', when calling this app from the command line,
the light on the webcam actually flashes blue so I am assuming it can
communicate with the device.

[peter at thruxton:~/tmp/webcam]% webcam   
reading config file: /home/peter/.webcamrc
video4linux webcam v1.5 - (c) 1998-2002 Gerd Knorr
grabber config:
  size 640x480 [16 bit YUV 4:2:2 (packed, YUYV)]
  input (null), norm (null), jpeg quality 80
  rotate=0, top=0, left=0, bottom=480, right=640
write config [ftp]:
  local transfer /home/peter/tmp/webcam/uploading.jpeg =>
ioctl: VIDIOC_DQBUF(index=0;type=VIDEO_CAPTURE;bytesused=0;flags=0x0
Invalid argument
capturing image failed
zsh: exit 1     webcam

I am not sure what is wrong here, to be honest I think it might be
something in my .webcamrc, I tired another program called `cheese' but
when I run this it washes out my entire desktop with white such that I
cannot read any text in the gui and have to log out of X.

Anyway, if someone knows of some other programs or tests I or the OP
might try, I would appreciate the help.



More information about the ubuntu-users mailing list