X won't start at boot with NVidia driver

Sven Richter sveri-list at gmx.de
Mon Feb 4 21:40:08 UTC 2008


Am Montag 04 Februar 2008 19:43:19 schrieb Ed Jabbour:
> Running kubuntu 7.10 on an HP laptop.  I downloaded the proper driver from
> the Nvidia site and it installed with no error messages.  I ran startx and
> no problems.  However, at a reboot, X would not start - screen not found. 
> I edited xorg.conf to load the vesa driver and got X.  The NVidia driver
> will not run correctly until I delete a number of libnvidia .so files and a
> few others from the /usr/lib directory.  It then installs and startx works,
> but not at reboot.  The same process over and over.
>
> Any hints, pointers, etc appreciated.

I had the same problem with the old nvidia binary 1.0x49 iirc.
After booting i had to kill kdm, rmmod nvidia and the modprobe nvidia
again.
Aftwards x could be started.
I assume i messed up some things cause i tried the drivers from
the repos.

Then in installed the new binary driver 169.09 and the problem was fixed.


Greetings
Sven Richter






More information about the ubuntu-users mailing list