Ubuntu wireless SUCCESS!! (Re: cheap ubuntu laptop with wireless that works right "out of the box".)

Default User xyzzyx at sbcglobal.net
Sun Feb 3 00:49:51 UTC 2008

On Sat, 2008-02-02 at 18:30 -0600, Default User wrote:

> As promised, I am reporting back on wireless connectivity using the 
> Belkin F5D7050 usb wireless adapter, VERSION 4.000
> with Ubuntu 7.10 (32-bit for i386).  
> SUCCESS!!  I just stuck the adapter into a usb hub, cold booted my old
> desktop '586, and prepared for more disappointment. But no! Starting up
> the Gnome desktop, Network Manager showed the normal ethernet
> connection, eth0 as usual.  I right clicked NM, networking and wireless
> were both showing enabled. Good.  I left-clicked NM, and clicked the
> entry for my wireless network connection.  A window popped up asking for
> the encryption type and key, which I entered, and then clicked OK.
> After several seconds the NM icon showed a good strong connection!  
> Right-clicking and selecting "Connection Information" showed that the
> eth0 connection had been replaced by eth1, the wireless connection.  I
> then did sudo ifconfig -a. Both eth0 and eth1 showed as "up".  I did
> sudo ifconfig eth0 down.  Connection stayed on.  I pinged my network.
> No problems.  I then unplugged the ethernet cable from the eth0 network
> card.  Connection still up.  Again pinged the network.  Still no
> problems.  I then browsed and check email, using the wireless
> connection.  I works fine!  Then took a half-hour off to watch the news.
> Came back, connection still good. [Note: in a series of 23 pings to the
> network connection, the times varies significantly, from a high of
> 58.061 ms to a low of 2.255 ms.  Not necessarily indicative of a
> problem, but...  interesting.
> So, If you use Ubuntu and need wireless connectivity, and you see this
> adapter in a store or online, grab it, before the Microsoft MIBs have
> them quietly disappear forever.  Even if you don't need it now, you just
> might in the future.  Or some one else might. You never know. (I thought
> my adapter-hunting days were over when I found a Cardbus type wireless
> adapter, less than a year ago.  Now it's obsolete already.)   
> Just look for the box that says Belkin Wireless G USB Network Adapter,
> and Part #F5D7050 on the bottom of the box. 
> And BE SURE that the box says:
> "ver. 4.000" 
> on a white bar-coded label on the bottom of the box.  The box may also
> say (c) 2005 Belkin Corporation, again on the bottom of the box.  
> Note: "ver. 5000" does NOT work correctly, even using ndiswrapper.  I
> have also seen ver. 4001 and ver. 3002, I have not tried them, so I
> don't know if they work.  
> Chris Mohler, Thank You Very Much for tipping us off to this wireless
> adapter.  I really appreciate it!  

I forgot to mention that, best of all, the adapter works right out of
the box!  No need to install drivers or firmware, and ndiswrapper is not
needed at all. You can throw away the Windows driver install cd, unless
you dual-boot or . . .  actually use Windows only (Ewww, yuck!)

More information about the ubuntu-users mailing list