cheap ubuntu laptop with wireless that works right "out of the box".

Chris Mohler cr33dog at
Sat Feb 2 00:28:20 UTC 2008

On Feb 1, 2008 11:15 AM, Default User <xyzzyx at> wrote:
> Note: Chris Mohler said:
> "Alternatively:
> Buy yourself one of these: (~$40)
> Plug it in.
> Done.  I keep one of these with my laptop anyway - the signal is
> stronger than the built-in wireless."
> ----------------------------------------------------------------
> I'm glad it works for Chris, but I just got one, a Belkin F5D7050 usb
> adapter, version 5.000. Box says (c)2007.  I tried it on an old desktop
> pc Ubuntu 7.10, updated) with usb 1.0 sockets.  It absolutely would not
> work plugged into a usb hub.
> It would not work without using ndiswrapper-1.9 (thru the ndisgtk gui).
> Then it worked a few times erratically, then not at all.  For the few
> (2-3) times it did work, it would not scan in roaming mode unless
> explicitly told the name of the desired network connection first, and
> absolutely refused to make an encrypted connection at all.  I spent
> hours fighting with it.
> I could not recommend using this adapter, except in a limited case of
> dire desperation.  But thanks for the suggestion anyway.

Odd. Here is my dmesg when plugging it in:
[ 1945.796000] usb 7-3: new high speed USB device using ehci_hcd and address 3
[ 1945.928000] usb 7-3: configuration #1 chosen from 1 choice
[ 1946.196000] usb 7-3: reset high speed USB device using ehci_hcd and address 3
[ 1946.440000] zd1211rw 7-3:1.0: firmware version 4725
[ 1946.484000] zd1211rw 7-3:1.0: zd1211b chip 050d:705c v4810 high
00-17-3f AL2230_RF pa0 g--NS
[ 1946.488000] zd1211rw 7-3:1.0: eth2
[ 1946.488000] usbcore: registered new interface driver zd1211rw
[ 1946.580000] ADDRCONF(NETDEV_UP): eth2: link is not ready

I wonder if  newer ones use another chipset?  I've not had any trouble
using it on two desktops and one laptop so far (all Gutsy)- it's
instantly recognized by NetworkManager and WEP/WPA work well.  I even
bought one to put a friend's old clunker on the wireless at the
university.  It's definitely the same model - f5d7050.

I have never tried plugging it into a hub though - always the built-in
bus, probably usb 2.0 on all of them.

Sorry for the bad advice - thought it was a sure thing.


More information about the ubuntu-users mailing list