Can't make a /home partition

elmo elmo at
Fri Feb 1 14:17:54 UTC 2008

I'm trying to create a /home partition using the following instructions:

1. $mkdir /mnt/newhome
2. $sudo mount -t ext3 /dev/hdb2 /mnt/newhome

3. $cd /home/
4. $find . -depth -print0 | cpio –null –sparse -pvd /mnt/newhome/

5. $sudo umount /mnt/newhome
6. $sudo mv /home /old_home

7. $sudo mkdir /home

8. $sudo mount /dev/hdb2 /home

Add a line to the “/etc/fstab” file that looks like the following:
/dev/hdb2 /home ext3 nodev,nosuid 0 2

11 $sudo rm -r /old_home
I'm trying to set up /dev/hdb2 as the /home partiton. I've also tried

I haven't been able to get past step 4--------. I get a notice to the 
effect that
something is wrong with cpio with reference to cpio --help.

I've examined cpio --help, and man cpio but my level of understanding
gets in the way.

I've also tried a slightly different version of line 4: (sudo cpio)
$find . -depth -print0 | sudo cpio –null –sparse -pvd /mnt/newhome/

Can someone put me on the right path to make that cpio work?


The complete document can be seen on several websites, one of which

More information about the ubuntu-users mailing list