problem with CUPS

Zach Uram netrek at
Wed Dec 31 21:42:30 UTC 2008

I am using http://localhost:631/admin and click Add Printer and select
HP960C and the hplip driver then when I apply it says: 413 Request
Entity Too Large

I am running firefox as root so I don't know why it is failing. I also
tried running gnome-cups-manager as root which calls gnome-cups-add
and it says:

** (gnome-cups-add:28853): WARNING **: IPP request failed with status 1280

I found this is /var/log/cups/error_log:
E [31/Dec/2008:08:15:02 -0500] CUPS-Add-Modify-Printer: Unauthorized

I ran as root this time (sudo) so I don't understand why it is saying
I am unauthorized.

And I found this in /var/log/cups/access_log:
localhost - - [31/Dec/2008:08:14:18 -0500] "POST / HTTP/1.1" 200 1652
CUPS-Get-Devices -
localhost - - [31/Dec/2008:08:14:26 -0500] "POST / HTTP/1.1" 200
652837 CUPS-Get-PPDs -
localhost - - [31/Dec/2008:08:15:02 -0500] "POST /admin/ HTTP/1.1" 401
352 CUPS-Add-Modify-Printer successful-ok
localhost - root [31/Dec/2008:08:15:02 -0500] "POST /admin/ HTTP/1.1"
200 352 CUPS-Add-Modify-Printer server-error-internal-error


More information about the ubuntu-users mailing list