can i install a non-.deb program?

Mike McGinn mikemcginn at mcginnweb.net
Wed Dec 31 20:48:46 UTC 2008


On Wednesday 31 December 2008 15:44:18 Nigel Henry wrote:
> On Wednesday 31 December 2008 19:55, Derek Broughton wrote:
> > Koh Choon Lin wrote:
> > >>> Are you referring to this?
> > >>> http://www.cabaret-solutions.com/en/downloads/linux
> > >>
> > >> yes, that's the one.  i'll take a peek in the archive and see if there
> > >> is any documentation.
> > >
> > > They are in .tgz format so I suppose they are likely to be binary or
> > > packaged for Slackware.
> >
> > Not particularly likely.  That's what's known as a "tarball", and is the
> > way _source_ software is usually distributed.  You unzip, enter the top
> > level directory, and do "./configure; make; sudo make install"
>
> Well I'm currently downloading it on dialup. Not on Ubuntu, but Kubuntu
> Intrepid, as I can use Kget which has resume support, and the package is a
> bit large at 33.3MB. The last thing I want is to get 99% downloaded, then
> lose my connection. I'm not too clued up on what Gnome uses as download
> manager, and if it has resume support.
>
> Once it's downloaded, I'm preparing myself for dependency hell, when trying
> to build it. No deps listed on the webpage, but there may be something in
> the README, or INSTALL files in the tarball. Of course "make" may just run
> to completion with no errors, but I somehow doubt it from past experience
> in trying to build some audio apps that need the latest, and greatest libs
> in order to build. At the moment I'm giving "make" a 50/50 chance of
> running to completion, but fully expect it to throw in the towel with some
> obscure error.
>
> I'll be back in a couple of hours, when the download has completed, and
> I've tried building it.
>
> 47% now downloaded, as it takes me so long to compose replies, so, I'll be
> back in an hour or so with the results.
>
> What a way to spend the last day of the year, sat in front of 2 monitors.
> All a bit sad, but I have a few beers at hand.
>
> Nigel.
I downloaded and tried it (curious guy I am). It is a Java program and it 
seemed to run fine for me when I invoked it from the shell. There was no 
building involved.



-- 
Mike McGinn
Registered Linux User 377849
"more kidneys than eyes!"
Code wrangling for over twenty years.
"Forsan et haec olim meminisse iuvabit."




More information about the ubuntu-users mailing list