ipods on ubuntu

Hal Burgiss hal at burgiss.net
Mon Dec 29 23:03:57 UTC 2008

On Mon, Dec 29, 2008 at 12:17:43PM -0700, Leif Gregory wrote:
> On Mon, 29 Dec 2008 13:30:49 -0500
> "Michael Haney" <thezorch at gmail.com> wrote:
> > I'm considering an iPod Touch.  Has anyone tried using an iPod Touch
> > with any of the iPod friendly software on Ubuntu (ie; gtkipod, Amarok,
> > Songbird, etc)?
> Yep. I used Amarok with my iPod Touch for a while. It's been a few
> months though. It worked pretty good, but it was a semi-rough
> experience. Every once in a while it'd get all confused and I'd have to
> delete the iPod folder on the computer for it to work again. Every time
> I updated the firmware I'd have to blow away the SSH keyring and do it
> again. Neither of those were biggies, just irritating.
> I've played with a lot of MP3 players (or rather, portable music
> players) and while I don't particularly care for Apple, it's ethics,
> or it's lack of openness, I have to admit I love my iPod Touch. It's
> sexy, it's fun, and jailbreaking let's me use it the way I want to
> (except for the Linux part). I haven't bought an iPhone because I just
> can't bring myself to lock in like that. I'll wait a bit longer and go
> for an Android based phone. Just didn't like the G1.

This is just a catch up of my trials on this, in case anyone is

I have a similar family arrangement where more than one person will be
accessing the music (and of course the ipod). While I am happy as a
lark on 100% Linux and open source solutions, that hasn't percolated.

I am personally using gtkpod to sync music from Ubuntu to ipod
(mp3's). This has worked well enough. I can create playlists, copy
files, etc and the ipod so far has recognized all the music. Something
trashed all the default album art, and I haven't gotten that back. But
not a big deal to me.

I use rhythmbox for playing from the desktop. This of course works
fine with mp3's. There is some iTunes dl'd music on the ipod. Oddly,
there is one iTunes song that works (a very old blues thing), but
everything else generates errors due to the encryption from iTunes. I
guess this is going to be a no go. 

The bad news: I have had 4 or 5 occasions where something has locked
the system up hard. Real hard. It would not respond to pings, and
networking was totally fubar. Trying to restart networking (local
terminal access is still alive at this point), results in a hung
terminal and a fubar system, that requires a reset button restart. The
best I can tell this only happens when using one of the GUI apps to
eject the ipod. It does not happen during usage otherwise. My hunch is
something is unloading module, maybe, that something else is dependent
on. There's nothing in any log file.


More information about the ubuntu-users mailing list